summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2022-11-14 11:24:19 -0300
committerDaniel Bermond2022-11-14 11:24:19 -0300
commitf8badfe9d93507609f97e077a2abafd8c175acd6 (patch)
tree24959c75b086d4a7206add4316b66c83ad1693c5 /PKGBUILD
parenta52961f704a974522e1711f367218a2ea25da5b7 (diff)
downloadaur-avbin-git.tar.gz
Fix git submodules. Disable lto to fix build. Cosmetic changes.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 13 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5514296dbdbf..8e7f91f11192 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond < gmail-com: danielbermond >
pkgname=avbin-git
-pkgver=10.r60.g6a8ea87
+pkgver=10.r61.g92d515a
pkgrel=1
pkgdesc='A C library that provides a wrapper around Libav’s video and audio decoding functionality (git version)'
arch=('x86_64')
@@ -11,6 +11,7 @@ depends=('bzip2' 'zlib')
makedepends=('git' 'yasm')
provides=('avbin')
conflicts=('avbin')
+options=('!lto')
source=('git+https://github.com/AVbin/AVbin.git'
'libav-avbin'::'git+https://github.com/AVbin/libav.git'
'0001-avbin-remove-unwanted-optimization.patch'
@@ -19,35 +20,28 @@ source=('git+https://github.com/AVbin/AVbin.git'
'avbin.pc')
sha256sums=('SKIP'
'SKIP'
- '8f8b20d6e57bdc6bf73723691740ae35b157785ebda5764a7611a68df427c30a'
- 'fa8f7263326b10f968836f5fe7ae9efef04cdce58a28cfd3f7cb93985fffb469'
- '5629f9f239b5dafb8ded30224136854ee8fda537d5e528f9db35450bf057a5ad'
+ 'cd44745477803d96d9cf762c4004b7d53c0b84e5a6ba4a3c1f5ce46f4572a2ca'
+ 'a177c0906928338113469c688d309ae8e95a753de35c2a73bff02b6d99de6008'
+ 'c86083e6286af140dbb97b39a06c778bffad5557bb9f46465f6b7a2e050cbe97'
'd601ceed81c584d7af1d4cb0217e7ab34b7973232a81a09ce24eb620b4796199')
prepare() {
- cd AVbin
-
- git submodule init
- git config --local "submodule.libav.url" "${srcdir}/libav-avbin"
- git submodule update
+ git -C AVbin submodule init
+ git -C AVbin config --local "submodule.libav.url" "${srcdir}/libav-avbin"
+ git -C AVbin -c protocol.file.allow='always' submodule update
- patch -Np1 -i "${srcdir}/0001-avbin-remove-unwanted-optimization.patch"
- patch -Np1 -i "${srcdir}/0002-avbin-fix-link-and-add-full-relro.patch"
- patch -Np1 -i "${srcdir}/0003-avbin-faster-build.patch"
+ patch -d AVbin -Np1 -i "${srcdir}/0001-avbin-remove-unwanted-optimization.patch"
+ patch -d AVbin -Np1 -i "${srcdir}/0002-avbin-fix-link-and-add-full-relro.patch"
+ patch -d AVbin -Np1 -i "${srcdir}/0003-avbin-faster-build.patch"
}
pkgver() {
- cd AVbin
-
- # git, tags available
- git describe --long --tags | sed 's/^avbin-//;s/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
+ git -C AVbin describe --long --tags | sed 's/^avbin-//;s/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
build() {
cd AVbin
-
- unset LDFLAGS # won't build if setted, modified by patch
-
+ unset -v LDFLAGS # won't build if setted, modified by patch
./build.sh --fast linux-x86-64
}