summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJorge Barroso2015-06-15 21:32:20 +0200
committerJorge Barroso2015-06-15 21:32:20 +0200
commitb032a128d3b9cf6e261905a51b404df193242431 (patch)
tree87d65eac340638cd422dcabcdd71a27f324f04d7 /PKGBUILD
downloadaur-baamanga-git.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de27c88e8f0e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+#!/bin/sh
+# Maintainer: Jorge Barroso <jorge.barroso.11@gmail.com>
+
+pkgname=baamanga-git
+pkgver=0.5.6.r0.gbbb7604
+pkgrel=1
+pkgdesc="Command-line tool to download manga from lots of websites. Git version"
+arch=('i686' 'x86_64')
+url="http://baamanga.tk"
+license=('GPL2')
+depends=('curlcpp-git' 'boost-libs')
+makedepends=('boost')
+provides=(baamanga)
+conflicts=(baamanga)
+install=baamanga.install
+source=(baamanga::"git://git.code.sf.net/p/baamanga/code")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/baamanga"
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build(){
+ cd "$srcdir/baamanga"
+ autoreconf --install
+ ./configure
+ make
+}
+
+package() {
+ cd "${srcdir}/baamanga"
+ make DESTDIR=${pkgdir} install
+}
+
+# vim:set ts=2 sw=2 et: