summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSebastian Wilzbach2015-06-16 21:29:40 +0200
committerSebastian Wilzbach2015-06-16 21:29:40 +0200
commit3e7f5528ba446e58c6f5f13d45138e5a3d942540 (patch)
tree2e0b21931829507244f0fab4322effe48c327770 /PKGBUILD
downloadaur-backup-luks.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e7b258704b78
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Sebastian Wilzbach <sebi at wilzbach dot me>
+pkgname=backup-luks
+pkgrel=1
+pkgver=v5
+pkgdesc="Convenient wrapper for running encrypted backups with rsync"
+arch=('any')
+url="https://github.com/greenify/backup-luks"
+license=('GPL3')
+groups=()
+depends=('python' 'gdisk' 'bash' 'sh' 'python-gobject')
+makedepends=('git')
+optdepends=('cronic')
+source=('git+https://github.com/greenify/backup-luks.git')
+provides=('backup-luks')
+
+package() {
+ cd $pkgname
+
+ # binaries
+ mkdir -p $pkgdir/usr/bin/
+ cp backup-luks $pkgdir/usr/bin
+ cp create_disk $pkgdir/usr/bin
+ cp create_partition $pkgdir/usr/bin
+
+ # shared
+ mkdir -p $pkgdir/usr/share/backup-luks
+ cp backup-example $pkgdir/usr/share/backup-luks
+ cp README.md $pkgdir/usr/share/backup-luks
+
+ # replace script dir
+ sed -e 's/DIR="\$.*/DIR=\/usr\/bin\/backup-luks/' -i $pkgdir/usr/share/backup-luks/backup-example
+
+ msg2 ""
+ msg2 "You can find an example script under /usr/share/$pkgname/backup-example"
+ msg2 ""
+}
+
+pkgver() {
+ cd $pkgname
+ echo "v"$(git rev-list --count master)
+}
+
+md5sums=('SKIP')
+
+# vim:set ts=2 sw=2 et: