summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatthew McGinn2020-01-08 11:12:47 -0500
committerMatthew McGinn2020-01-08 11:12:47 -0500
commit087227a2593a78fbf53f443fde66fd33697f21b3 (patch)
tree834f8e6312ca31988c901bb4857862e1a2e2fa04 /PKGBUILD
parent9de9dd232174d2562dbfcd2b8749911d4f10bb6d (diff)
downloadaur-087227a2593a78fbf53f443fde66fd33697f21b3.tar.gz
fixup: if submodule checkout fails, use the master branch
Signed-off-by: Matthew McGinn <mamcgi@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 7 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8ab71d6f0af2..02a06e07bfed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,37 +5,34 @@
pkgname=balena-etcher
_pkgname=etcher
pkgver=1.5.70
-pkgrel=3
+pkgrel=4
epoch=2
pkgdesc='Flash OS images to SD cards & USB drives, safely and easily'
arch=(x86_64)
_github_url='https://github.com/balena-io/etcher'
url='https://etcher.io'
license=(Apache)
-depends=(electron6 gtk2 libxtst libxss gconf nss alsa-lib nodejs)
-makedepends=(npm python2 git jq)
-optdepends=('libnotify: for notifications'
- 'speech-dispatcher: for text-to-speech')
+depends=("electron6" "gtk3" "libxtst" "libxss" "nss" "alsa-lib" "nodejs" "glib2" "polkit" "libusb")
+makedepends=("npm" "python2" "git" "jq")
+optdepends=("libnotify: for notifications")
conflicts=("${_pkgname}"
"${_pkgname}-git"
"${_pkgname}-bin"
)
options=('!strip')
source=("etcher::git+https://github.com/balena-io/${_pkgname}.git#tag=v${pkgver}"
- 'git+https://github.com/balena-io/scripts.git'
"${pkgname}-electron"
"${pkgname}-electron.desktop"
)
sha256sums=('SKIP'
- 'SKIP'
'911cca26a477c0525085410c78cd9292dc4b6bd27fb7340034fe762d333a3f52'
- 'c950d9578f9cf60998c920bb60c6617559963f06a4918e7072fdc706b0ef5754')
+ 'c950d9578f9cf60998c920bb60c6617559963f06a4918e7072fdc706b0ef5754'
+ )
prepare() {
cd "${_pkgname}"
git submodule init
- git config submodule.scripts/resin.url "${srcdir}/scripts"
- git submodule update
+ git submodule update || cd "${srcdir}/${_pkgname}/scripts/resin" && git checkout --
}
build() {