summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKyle Keen2015-06-13 00:09:06 -0400
committerKyle Keen2015-06-13 00:09:06 -0400
commit35c4fe9efe4c35a35285f0aecbd24cc5f5bf19df (patch)
tree055454eb677f1e232c281d265013190389b39a5a /PKGBUILD
downloadaur-bandicoot-git.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f6aa816373e7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Kyle Keen <keenerd@gmail.com>
+
+pkgname=bandicoot-git
+pkgver=20110702
+pkgrel=1
+pkgdesc="A relational set based programming system."
+url="http://bandilab.org/"
+arch=('i686' 'x86_64')
+license=('Apache')
+depends=('glibc')
+makedepends=('git')
+conflicts=("bandicoot")
+provides=("bandicoot")
+source=('git://github.com/bandilab/bandicoot.git')
+md5sums=('SKIP')
+
+_rootname=bandicoot
+
+pkgver() {
+ cd "$_rootname"
+ git show -s --format="%ci" HEAD | sed -e 's/-//g' -e 's/ .*//'
+}
+
+build() {
+ cd "$_rootname"
+ case $CARCH in
+ 'i686')
+ ./ctl dist -m32 ;;
+ 'x86_64')
+ ./ctl dist -m64 ;;
+ esac
+}
+
+package() {
+ cd "$_rootname"
+ install -Dm755 bandicoot-v3/bandicoot "$pkgdir/usr/bin/bandicoot"
+}
+