summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrey Mukhin2019-01-20 22:48:59 +0300
committerAndrey Mukhin2019-01-20 22:48:59 +0300
commit2487dc2550407df1d661afc4485bdbd27932edbc (patch)
tree2aafde1638929383ce7925fe626c926201fd1cde /PKGBUILD
downloadaur-bashful.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..10c3a4f1e4e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Andrey Mukhin <andrey@nufl.ru>
+
+pkgname=bashful
+pkgver=0.1.1
+pkgrel=1
+pkgdesc='Shell scripts executor with ansible-like yaml configuration.'
+arch=('x86_64')
+url='https://github.com/wagoodman/bashful'
+license=('MIT')
+depends=('glibc')
+
+source=("https://github.com/wagoodman/bashful/releases/download/v${pkgver}/${pkgname}_${pkgver}_linux_amd64.tar.gz")
+sha256sums=('ab9c8609df08bebf98d9b3ec9ce7d2f752cf77644c97f355bfa12a18b73f3ac6')
+
+package() {
+ install -Dm755 \
+ "${pkgname}" \
+ "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 \
+ "LICENSE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}