summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoréclairevoyant2023-05-16 02:29:47 -0400
committeréclairevoyant2023-05-16 02:29:47 -0400
commit72b52b1da61e3e45f6ffaf6d4c3e87a42c3d6d9d (patch)
treea6928fe5522de0e5562c20fd4dc789ec6682b38a /PKGBUILD
downloadaur-bashplus.tar.gz
bashplus: init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3d0130abe05
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: éclairevoyant
+
+pkgname=bashplus
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Collection of useful Bash functions"
+arch=(any)
+url="https://github.com/ingydotnet/$pkgname"
+license=(MIT)
+depends=(bash)
+makedepends=(git)
+source=("git+$url.git?commit=030d196bf621e971e223e95e73c235e6992b85e0")
+b2sums=('SKIP')
+_libname=bash+
+
+package() {
+ cd $pkgname
+ install -vDm755 lib/$_libname.bash -t "$pkgdir/usr/lib/"
+ install -vDm644 man/man3/$_libname.3 -t "$pkgdir/usr/share/man/man3/"
+ install -vDm644 License "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}