summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntony Lee2016-05-25 08:48:09 -0700
committerAntony Lee2016-06-26 22:06:17 -0700
commit436ca112b6b2aed0d20a9f681ce4880e9b7ae288 (patch)
tree08814e9b40a4f4a7d7f6720695eabe6249a73c30 /PKGBUILD
parentfb957a028dc8c84c0ce80860a39f0c4b8395954e (diff)
downloadaur-bcalc.tar.gz
Update to 16.05.0.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD55
1 files changed, 28 insertions, 27 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 14ca51a6a89b..2b44a246d4c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,45 +5,46 @@
# Note: only x86_64 is supported. The PKGBUILD for version 13.01.0 is the
# latest that supports i686.
pkgname=bcalc
-pkgver=15.12.0
+pkgver=16.05.0
pkgrel=1
pkgdesc='Double-dummy solver for bridge (the card game).'
arch=('i686' 'x86_64')
url='http://www.bcalc.w8.pl'
license=('custom')
-depends=('lua52' 'libcurl-gnutls')
+depends=('lua52' 'qt5-base')
options=('!strip')
source=("${url}/download/bcalc_linuxpkgdevel_09.tar.gz"
"${url}/download/bcalc${pkgver//./}_linux_x86-64.tar.gz")
md5sums=('32ebb622ae7ef95626279a0dfc877964'
- '178b8f22fa8aec26a15d68732553a484')
+ '457c79f739811c06d291707b8f14bf4f')
package() {
- cd $srcdir
+ cd $srcdir
- install -D -m644 bcalc.desktop $pkgdir/usr/share/applications/bcalc.desktop
- install -D -m644 bcalc.png $pkgdir/usr/share/pixmaps/bcalc.png
-
- install -d $pkgdir/usr/share/locale/pl/LC_MESSAGES/
- install -D -m644 i18n/pl/LC_MESSAGES/* $pkgdir/usr/share/locale/pl/LC_MESSAGES/
+ install -D -m644 bcalc.desktop $pkgdir/usr/share/applications/bcalc.desktop
+ install -D -m644 bcalc.png $pkgdir/usr/share/pixmaps/bcalc.png
- libdir=/var/lib/bcalc
- install -d $pkgdir/$libdir/downloaders
- install -D -m644 downloaders/* $pkgdir/$libdir/downloaders
- install -m755 bcalcqtgui $pkgdir/$libdir/bcalcqtgui
- install -m755 bcalconsole $pkgdir/$libdir/bcalconsole
- install -m755 bdeal $pkgdir/$libdir/bdeal
- ln -s /usr/lib/liblua5.2.so $pkgdir/$libdir/liblua5.2.so.0
+ install -d $pkgdir/usr/share/locale/pl/LC_MESSAGES/
+ install -D -m644 i18n/pl/LC_MESSAGES/* $pkgdir/usr/share/locale/pl/LC_MESSAGES/
- install -d $pkgdir/usr/bin
- # fix libcurl version
- echo -e '#!'"/bin/sh\nLD_LIBRARY_PATH=$libdir $libdir/bcalcqtgui\n" > bcalcqtgui
- chmod +x bcalcqtgui
- install -m755 bcalcqtgui $pkgdir/usr/bin/bcalcqtgui
- echo -e '#!'"/bin/sh\nLD_LIBRARY_PATH=$libdir $libdir/bcalconsole\n" > bcalconsole
- chmod +x bcalconsole
- install -m755 bcalconsole $pkgdir/usr/bin/bcalconsole
- echo -e '#!'"/bin/sh\nLD_LIBRARY_PATH=$libdir $libdir/bdeal\n" > bdeal
- chmod +x bdeal
- install -m755 bdeal $pkgdir/usr/bin/bdeal
+ libdir=/opt/bcalc
+ install -d $pkgdir/$libdir/downloaders
+ install -D -m644 downloaders/* $pkgdir/$libdir/downloaders
+ install -m755 bcalcqtgui $pkgdir/$libdir/bcalcgui
+ install -m755 bcalconsole $pkgdir/$libdir/bcalconsole
+ install -m755 bdeal $pkgdir/$libdir/bdeal
+ ln -s /usr/lib/liblua5.2.so $pkgdir/$libdir/liblua5.2.so.0
+
+ install -d $pkgdir/usr/bin
+
+ # bcalc links against liblua5.2.so.0 instead of liblua5.2.so
+ echo -e '#!'"/bin/sh\nLD_LIBRARY_PATH=$libdir $libdir/bcalcgui\n" > bcalcgui
+ chmod +x bcalcgui
+ install -m755 bcalcgui $pkgdir/usr/bin/bcalcgui
+ echo -e '#!'"/bin/sh\nLD_LIBRARY_PATH=$libdir $libdir/bcalconsole\n" > bcalconsole
+ chmod +x bcalconsole
+ install -m755 bcalconsole $pkgdir/usr/bin/bcalconsole
+ echo -e '#!'"/bin/sh\nLD_LIBRARY_PATH=$libdir $libdir/bdeal\n" > bdeal
+ chmod +x bdeal
+ install -m755 bdeal $pkgdir/usr/bin/bdeal
}