summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMusikolo2019-05-31 21:51:29 -0500
committerMusikolo2019-05-31 21:51:29 -0500
commitaeaf9fe6957e484d5aaa7d9c56b4a5d4776e32a4 (patch)
tree1c4101da5975a451a2fac329f36a90205e32d668 /PKGBUILD
parent38b6bed0392850ff416d416897b9650d959be85d (diff)
downloadaur-aeaf9fe6957e484d5aaa7d9c56b4a5d4776e32a4.tar.gz
Fix issue affecting posix-compliant systems when running install.sh script
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1cac5c8ed3b9..65346b5e5643 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@
pkgbase=bcompare
pkgname=('bcompare' 'bcompare-kde5' 'bcompare-kde4' 'bcompare-nautilus' 'bcompare-thunar' 'bcompare-cinnamon' 'bcompare-mate')
pkgver=4.2.10.23938
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
url='http://www.scootersoftware.com'
license=('custom')
@@ -69,7 +69,8 @@ package_bcompare() {
# Excecute install script - needs to be run here
cd "${pkgbase}-${pkgver}"
_install_dir="${srcdir}/install"
- sh install.sh --prefix="${_install_dir}"
+ sh -version &> /dev/null && sh install.sh --prefix="${_install_dir}"\
+ || bash install.sh --prefix="${_install_dir}"
# Prepare the directory skeleton needed for install.sh
cp -r "${_install_dir}/bin" "${pkgdir}/"