summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSaren Arterius2019-03-15 15:31:51 +0800
committerSaren Arterius2019-03-15 15:31:51 +0800
commit72e96e458e94d81da3f48168e69de25e89c789c8 (patch)
tree75112c224ae1b855b8e3e221fc03b0e8888fe316 /PKGBUILD
downloadaur-bedup-fork-git.tar.gz
first
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..daa0bb259e7f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Saren Arterius <saren@wtako.net>
+
+# Contributor: Oliver Mangold <o.mangold@gmail.com>
+# Maintainer: TheNiceGuy <gabrielpolloguilbert@gmail.com>
+
+pkgname=bedup-fork-git
+_pkgname=bedup
+pkgver=0.10.1
+pkgrel=2
+pkgdesc="Offline deduplication utility for the BTRFS filesystem. Git, forked to fix some issues"
+arch=('i686' 'x86_64' 'aarch64')
+license=('GPL')
+depends=('python' 'python-distribute' 'python-alembic' 'python-sqlalchemy'
+ 'python-cffi' 'python-xdg' 'python-mako')
+makedepends=('gcc' 'btrfs-progs')
+url="https://github.com/g2p/bedup"
+conflicts=('vpaint-git' 'bedup' 'bedup-git')
+provides=()
+source=("git+https://github.com/galvanized/bedup.git")
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/$_pkgname"
+
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+
+ python setup.py install --root "$pkgdir"
+}