summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordpellegr2021-09-07 16:58:39 +0200
committerdpellegr2021-09-07 16:58:39 +0200
commiteaf62e4c548bd3ff8f807d0d4c63ae902ddd9735 (patch)
treefc367704e8d49734dd8613ba7e5513ea08027657 /PKGBUILD
parent826a9a8e199b32af2137b4d3430c26d9866bcaa3 (diff)
downloadaur-bfg-git.tar.gz
Removed the no-politics patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 3 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 046933bd43b5..dbcf5316e18e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname=bfg-git
_gitname=bfg-repo-cleaner
pkgver=r465.aeee9e3
pkgrel=1
-pkgdesc='Removes large blobs like git-filter-branch does, but faster. Git version, no politics.'
+pkgdesc='Removes large blobs like git-filter-branch does, but faster.'
url='https://github.com/rtyley/bfg-repo-cleaner'
arch=('any')
license=('GPL3')
@@ -12,22 +12,15 @@ depends=('java-runtime>8' 'bash')
makedepends=('sbt')
conficts=('bfg')
source=("git+https://github.com/rtyley/bfg-repo-cleaner.git"
- "bfg.sh"
- "clean.patch")
+ "bfg.sh")
sha256sums=('SKIP'
- 'a41ad8ff48364c1118e69f5c1c6c5c070d56ad1d2f9cd09bca3c095385a6b530'
- '99088f640a8ae89521eb5c5bfbdd96be348b1ccd6ba5072e4727247a04462782')
+ 'a41ad8ff48364c1118e69f5c1c6c5c070d56ad1d2f9cd09bca3c095385a6b530')
pkgver() {
cd "$_gitname"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "$_gitname"
- patch --forward --strip=2 --input="${srcdir}/clean.patch"
-}
-
build() {
cd "$_gitname"
sbt "bfg/assembly"