summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorblek2023-11-03 15:30:51 +1000
committerblek2023-11-03 15:30:51 +1000
commit2fde3f788ee5976a81d76cde38a310e2f014ed1e (patch)
tree3d49cb693d1f4364d0dc9f60e45b76bcaff07cb1 /PKGBUILD
downloadaur-bfile-cli.tar.gz
init repo
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8eba3929adea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: blek! <me@blek.codes>
+pkgname=bfile-cli
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='The blek! File CLI'
+arch=('i686' 'pentium4' 'x86_64' 'arm' 'armv7h' 'armv6h' 'aarch64' 'riscv64')
+url='https://git.blek.codes/blek/bfile_cli'
+provides=('bfile-cli')
+conflicts=('bfile-cli')
+options=(!lto)
+license=('GPL3')
+depends=(
+ 'pacman>5'
+ 'git'
+)
+makedepends=('go>=1.21.3')
+source=("${pkgname}-${pkgver}.tar.gz::https://git.blek.codes/blek/bfile_cli/archive/${pkgver}.tar.gz")
+sha256sums=('470022e1a77a0fbd864c251cb3bbab45c568a3f7985643e3b39add5f4299b31a')
+
+build() {
+ export GOPATH="$srcdir"/gopath
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export CGO_ENABLED=1
+
+ cd "${srcdir}/bfile_cli"
+ go build .
+}
+
+package() {
+ cd "${srcdir}/bfile_cli"
+ install -Dm755 bfile_cli "${pkgdir}/usr/bin/bfile_cli"
+}