summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWouter de Vries2019-10-15 12:01:31 +0200
committerWouter de Vries2019-10-15 12:01:31 +0200
commitc9e4ad8a67bbe9f4cf8552b77678af27eefd53f6 (patch)
tree5d0f8cdc047259ebee54dc3eb4e927313f7d4fc8 /PKGBUILD
downloadaur-bgpscanner.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..683e8e95430a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Wouter de Vries <wouter@wbdv.nl>
+# Contributor: Wouter de Vries <wouter@wbdv.nl>
+pkgname=bgpscanner
+pkgver=1.0
+_pkgver=$pkgver-1
+pkgrel=1
+pkgdesc="C library designed to efficiently parse BGP routing information contained in RIB snapshots and UPDATE collection files provided by route collecting projects"
+arch=('x86_64')
+url="https://isolario.it/web_content/php/site_content/tools.php"
+depends=('zlib' 'xz' 'bzip2' 'lz4')
+license=('BSD')
+source=("https://isolario.it/tools/bgpscanner-1.0-1_20190320.tar.gz" "license")
+md5sums=('1a8386ebc66c9f8120e452c241c813da'
+ '5f7695a319c1dee44a4837cc1c05b092')
+
+build() {
+ cd "$pkgname-$_pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$_pkgver"
+
+ # Install bgpscanner binary
+ make DESTDIR="$pkgdir" install
+
+ # Install license
+ mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
+ install -m 644 ../license "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}