summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLukas Holzner2018-02-15 19:32:10 +0100
committerLukas Holzner2018-02-15 19:32:10 +0100
commit04f631afce07aeb73041c87b524a393ec82cd6b8 (patch)
tree03fa23de53de497c1810d6a7cf3006c4ebaf6d09 /PKGBUILD
parent4930975dd584ab330a90dae25b70f74b191e1002 (diff)
downloadaur-04f631afce07aeb73041c87b524a393ec82cd6b8.tar.gz
Fixed PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 502b9d63212b..a064bd305986 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,23 @@ pkgname=binfmt-support
pkgver=2.1.8
pkgrel=2
pkgdesc="register interpreters for various binary formats"
-arch=(i686 x86_64)
+arch=(any)
url="http://packages.debian.org/en/sid/binfmt-support"
license=('GPL')
-depends=('libpipeline')
+depends=('glibc' 'systemd' 'libpipeline')
makedepends=()
-source=(ftp://ftp.de.debian.org/debian/pool/main/b/binfmt-support/binfmt-support_$pkgver.orig.tar.gz
- binfmt-support.service)
-sha256sums=('ebad04db8444d2275d042b5074fa3e160bcf3e2c23ee9b660e75f5acd73618a2'
- 'efba2300b9f0c8c5c14696d2b25836d91edaaad8d30c64ed7d3eab0163b2553e')
+source=(
+ http://ftp.de.debian.org/debian/pool/main/b/binfmt-support/binfmt-support_$pkgver.orig.tar.gz
+ binfmts.service
+ )
+md5sums=(
+ 'b86d8a8d310e246f1e02b91366472681'
+ '0000a524a3d97583563a0d1d6f6b1ecb'
+ )
build() {
cd "$srcdir/$pkgname-$pkgver"
- ./configure --prefix=/usr --libexecdir=/usr/lib --sbindir=/usr/bin --localstatedir=/var
+ ./configure --prefix=/usr --libexecdir=/usr/lib --sbindir=/usr/bin
make
}
@@ -22,5 +26,5 @@ package() {
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir/" install
install -dm0755 $pkgdir/var/lib/binfmts
- install -Dm644 $srcdir/binfmt-support.service $pkgdir/usr/lib/systemd/system/binfmt-support.service
+ install -Dm755 ../binfmts.service $pkgdir/usr/lib/systemd/system/binfmts.service
}