summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEli Schwartz2018-02-27 19:42:28 -0500
committerEli Schwartz2018-02-27 19:42:28 -0500
commit56ff05a34cd7c291a1b4c9379f27dcd5e7f56969 (patch)
tree34700d33e5522d4e022db15671bc2ea3f54a3d31 /PKGBUILD
parent04f631afce07aeb73041c87b524a393ec82cd6b8 (diff)
downloadaur-56ff05a34cd7c291a1b4c9379f27dcd5e7f56969.tar.gz
Revert "Fixed PKGBUILD"
This reverts commit 04f631afce07aeb73041c87b524a393ec82cd6b8. In no sane world does this fix anything at all, instead a number of things have regressed. Specifically, the badly designed use of bash in the systemd service, the fact that an architecture-dependent package was casually switched to lie and claim it is an "any" package, moving away from the upstream naming for the service, and not cleaning up after being stopped.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 8 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a064bd305986..502b9d63212b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,19 @@ pkgname=binfmt-support
pkgver=2.1.8
pkgrel=2
pkgdesc="register interpreters for various binary formats"
-arch=(any)
+arch=(i686 x86_64)
url="http://packages.debian.org/en/sid/binfmt-support"
license=('GPL')
-depends=('glibc' 'systemd' 'libpipeline')
+depends=('libpipeline')
makedepends=()
-source=(
- http://ftp.de.debian.org/debian/pool/main/b/binfmt-support/binfmt-support_$pkgver.orig.tar.gz
- binfmts.service
- )
-md5sums=(
- 'b86d8a8d310e246f1e02b91366472681'
- '0000a524a3d97583563a0d1d6f6b1ecb'
- )
+source=(ftp://ftp.de.debian.org/debian/pool/main/b/binfmt-support/binfmt-support_$pkgver.orig.tar.gz
+ binfmt-support.service)
+sha256sums=('ebad04db8444d2275d042b5074fa3e160bcf3e2c23ee9b660e75f5acd73618a2'
+ 'efba2300b9f0c8c5c14696d2b25836d91edaaad8d30c64ed7d3eab0163b2553e')
build() {
cd "$srcdir/$pkgname-$pkgver"
- ./configure --prefix=/usr --libexecdir=/usr/lib --sbindir=/usr/bin
+ ./configure --prefix=/usr --libexecdir=/usr/lib --sbindir=/usr/bin --localstatedir=/var
make
}
@@ -26,5 +22,5 @@ package() {
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir/" install
install -dm0755 $pkgdir/var/lib/binfmts
- install -Dm755 ../binfmts.service $pkgdir/usr/lib/systemd/system/binfmts.service
+ install -Dm644 $srcdir/binfmt-support.service $pkgdir/usr/lib/systemd/system/binfmt-support.service
}