summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntoine Viallon2019-02-02 21:21:45 +0000
committerAntoine Viallon2019-02-02 21:21:45 +0000
commit5bdd69f657cc716e4cd55a45ccb33b76e1147ec8 (patch)
tree43c903ea18ebee33b3569327dd8a88b383989a22 /PKGBUILD
parent5a3f39042dbb2407df7150476505bea0aceba757 (diff)
downloadaur-5bdd69f657cc716e4cd55a45ccb33b76e1147ec8.tar.gz
Updated to version 2.2.0, use their boostrap script before building the package - makes things much easier
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 20 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 38dcde13f4f2..71be0a0df84c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,26 @@
+# Maintainer: Antoine Viallon <antoine.viallon@gmail.com>
pkgname=binfmt-support
-pkgver=2.1.8
-pkgrel=2
-pkgdesc="register interpreters for various binary formats"
+pkgver=2.2.0
+_pkgver=2.2.0 # For use with RC releases, to replace the - with _
+pkgrel=1
+pkgdesc="Arbitraty executable file format kernel extension"
arch=('i686' 'x86_64')
-url="https://packages.debian.org/en/sid/binfmt-support"
+url="https://git.savannah.gnu.org/cgit/binfmt-support.git/"
license=('GPL')
-depends=('libpipeline')
-options=('emptydirs')
-source=("http://http.debian.net/debian/pool/main/${pkgname:0:1}/${pkgname}/${pkgname}_${pkgver}.orig.tar.gz")
-sha256sums=('ebad04db8444d2275d042b5074fa3e160bcf3e2c23ee9b660e75f5acd73618a2')
+depends=('autoconf' 'automake')
+makedepends=('make' 'gcc')
+source=("https://git.savannah.gnu.org/cgit/binfmt-support.git/snapshot/$pkgname-$_pkgver.tar.gz")
+sha512sums=('b35238fa96f7e3201f7c9a70172ecd2c6b0be66e4735ff96c17ae2167f670a67c856d0fc1b0d50bf3c14f4a35c5e9927a848814791ea9be928dff82426cb0da4')
+
+prepare() {
+ set -e
+ cd "${srcdir}/$pkgname-$_pkgver"
+ ./bootstrap
+}
build() {
- cd "$srcdir/$pkgname-$pkgver"
+
+ cd "${srcdir}/$pkgname-$_pkgver"
./configure --prefix=/usr \
--libexecdir=/usr/lib \
--sbindir=/usr/bin \
@@ -23,4 +32,6 @@ build() {
package() {
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir/" install
+ #install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE" # Couldn't find any License !
}
+