summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDario Ostuni2020-11-28 16:34:16 +0100
committerDario Ostuni2020-11-28 16:34:16 +0100
commit4b05b9d989ce0652689006afc57b9e99de59e5e6 (patch)
tree114054c23f612970805483f26c600ee551aff6b7 /PKGBUILD
parente5b8fbb79bcbe21e502de7828111ef8c9253b323 (diff)
downloadaur-binfmt-wasm.tar.gz
Better CLI arguments handling
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8ea04607fce9..728c4576f6a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,19 @@
# Maintainer: Dario Ostuni <dario.ostuni@gmail.com>
pkgname=binfmt-wasm
-pkgver=20190907
+pkgver=20201128
pkgrel=1
pkgdesc="Register wasmtime interpreter for wasm format"
arch=('any')
url="http://www.freedesktop.org/software/systemd/man/binfmt.d.html"
license=('MPL2')
depends=('wasmtime')
-source=("wasm.conf")
-sha384sums=('a7f7237a20bfd41484e6abfe1d5224cdd6ca1f7e563c04ef8b80c0a7e9893c2a5d6a34876e85ef7275d06ae7c9242c23')
+source=("wasm.conf"
+ "binfmt-wasmtime-wrapper")
+b2sums=('0e71d92e434a21000beb0425f0931ed662453c5f93ce81772e191d34a42bb3753de21a57888fba70320ececd7e27566f404fec90e8fadbafda97cedc89096c11'
+ '4eab85549930360e8705208189bf1cfa6753120162034bf00249b07b6573d3cadb211ee7c0fc1f0ddb056280fb5dd8c61064af16dd089da5b80fbc599d7d2510')
package() {
+ install -Dm 755 "$srcdir/binfmt-wasmtime-wrapper" "$pkgdir/usr/bin/binfmt-wasmtime-wrapper"
install -Dm 644 "$srcdir/wasm.conf" "$pkgdir/usr/lib/binfmt.d/wasm.conf"
}