summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwillemw122024-02-14 15:26:16 +0100
committerwillemw122024-02-14 15:26:16 +0100
commit50834bc70fe97f1b83ffb29fca62b8dd6fc33628 (patch)
treeba7a514c5a0d4fca4aadc1c98c629649c24521a0 /PKGBUILD
parent9fdb58af5427667720f64f8bdc8222927854bfae (diff)
downloadaur-biodiff.tar.gz
Set "target" inside package source folder
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 125591786ef7..7d44f7c45ba5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,13 +17,13 @@ prepare() {
}
build() {
- RUSTUP_TOOLCHAIN=stable cargo build --release --manifest-path=$pkgname-$pkgver/Cargo.toml --target-dir=target --all-features
+ RUSTUP_TOOLCHAIN=stable cargo build --release --manifest-path=$pkgname-$pkgver/Cargo.toml --target-dir=$pkgname-$pkgver/target --all-features
}
check() {
- RUSTUP_TOOLCHAIN=stable cargo test --release --manifest-path=$pkgname-$pkgver/Cargo.toml --target-dir=target
+ RUSTUP_TOOLCHAIN=stable cargo test --release --manifest-path=$pkgname-$pkgver/Cargo.toml --target-dir=$pkgname-$pkgver/target
}
package() {
- install -Dm755 target/release/$pkgname -t "$pkgdir/usr/bin"
+ install -Dm755 $pkgname-$pkgver/target/release/$pkgname -t "$pkgdir/usr/bin"
}