summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2021-04-07 23:51:49 +0200
committerhaawda2021-04-07 23:51:49 +0200
commit5ca21dad49ef4998565255b56fb1bbdd62de1672 (patch)
tree781861f3357aaffa7dd24c3233bb607ebf034927 /PKGBUILD
parent3818efe26dd4832bceba5186008ccdabae65d62a (diff)
downloadaur-birdie-git.tar.gz
complete rewrite
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 21 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 230d144c6d55..41f895c51338 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,36 @@
-# Maintainer: Frederic Bezies <fredbezies at gmail dot com0
-# Contributor : Ivo Nunes <ivoavnunes at gmail dot com>
-_pkgname="birdie"
-pkgname="${_pkgname}-git"
-pkgver=1.1+git.106.gba4adb3
+# Contributor: Frederic Bezies <fredbezies at gmail dot com0
+# Contributor: Ivo Nunes <ivoavnunes at gmail dot com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=birdie-git
+pkgver=1.1.r12.g20b3c83
pkgrel=1
pkgdesc="Twitter client for Linux"
-arch=('i686' 'x86_64')
-url="https://github.com/ivonunes/birdie"
+arch=('any')
+url="https://github.com/mizhka/birdie"
license=('GPL3')
-depends=('glib2' 'gtk3' 'hicolor-icon-theme' 'vala' 'granite' 'libpurple' 'gtksourceview3' 'libdbusmenu-gtk3' 'webkit2gtk')
-makedepends=('git' 'desktop-file-utils' 'hicolor-icon-theme' 'intltool' 'yelp-tools' 'gnome-common' 'gobject-introspection' 'meson' 'ninja')
-options=('!libtool')
+depends=('glib2' 'gtk3' 'hicolor-icon-theme' 'vala' 'granite' 'libpurple'
+ 'gtksourceview3' 'libdbusmenu-gtk3' 'webkit2gtk')
+makedepends=('git' 'desktop-file-utils' 'hicolor-icon-theme' 'intltool'
+ 'yelp-tools' 'gnome-common' 'gobject-introspection')
conflicts=('birdie' 'birdie-bzr')
provides=('birdie')
-source=("${_pkgname}::git+https://github.com/ivonunes/birdie.git")
+source=("git+$url.git")
md5sums=('SKIP')
pkgver() {
- cd "${_pkgname}"
- echo $(git describe --tags | sed s'/v\.//;s/-/./g')
+ cd ${pkgname%-git}
+ echo $(git describe --tags | sed s/+git./.r/ | sed s'/v\.//;s/-/./g')
}
build() {
- cd "${_pkgname}"
- arch-meson build \
- -Db_pie=false
- ninja -C build
+ cd ${pkgname%-git}
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
}
package() {
- cd "${_pkgname}"
- DESTDIR="${pkgdir}/" ninja -C build install
+ cd ${pkgname%-git}
+ DESTDIR="${pkgdir}/" make install
}