aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMilo Gilad2018-02-19 12:44:57 -0500
committerMilo Gilad2018-02-19 12:44:57 -0500
commit58eb1b21d7fef9ba6c8ee8a4e449d143c44c936d (patch)
tree8dd2c6126530c6808a2ddde093324d362c052e83 /PKGBUILD
downloadaur-58eb1b21d7fef9ba6c8ee8a4e449d143c44c936d.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..71c4a365c5cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Generated by debtap
+# Maintainer: Milo Gilad <myl0gcontact@gmail.com>
+pkgname=bitwarden
+pkgver=0.0.5
+pkgrel=1
+pkgdesc="A secure and free password manager for all of your devices."
+arch=('x86_64')
+url="https://bitwarden.com"
+license=('GPL')
+groups=('')
+depends=('alsa-lib' 'atk' 'cairo' 'dbus' 'electron' 'expat' 'fontconfig' 'freetype2' 'gconf' 'gdk-pixbuf2' 'glib2' 'gtk2' 'libcups' 'libnotify' 'libsecret' 'libx11' 'libxcb' 'libxcomposite' 'libxcursor' 'libxdamage' 'libxext' 'libxfixes' 'libxi' 'libxrandr' 'libxrender' 'libxss' 'libxtst' 'nspr' 'nss' 'pango')
+options=('!strip' '!emptydirs')
+install=${pkgname}.install
+source_x86_64=("https://github.com/bitwarden/desktop/releases/download/v${pkgver}/bitwarden_${pkgver}_amd64.deb")
+sha512sums_x86_64=('8ba003dcc8fd28aeee7d37981cd5e60b6dd8df05fb8005114e60bc12c3e10d1ef209dcaefa76005de56049e0d7a023c1db8bfcf660239732f6a42c6df2578193')
+
+package(){
+
+ # Extract package data
+ tar xf data.tar.xz -C "${pkgdir}"
+
+ install -D -m644 "/opt/Bitwarden/LICENSES.chromium.html" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+}