summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabian Bornschein2020-11-14 14:32:42 +0100
committerFabian Bornschein2020-11-14 14:32:42 +0100
commit8d304277ffc07a231cb246704191d093b08e09eb (patch)
tree970f0bfdd786aa728d693a2c0f1039a1bbde065a /PKGBUILD
downloadaur-blacklist-hw-watchdog.tar.gz
The true success lies in earning satisfaction in life instead of money.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa01505ac75d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Fabian Bornschein <plusfabi-cat-gmail-dog-com>
+
+pkgname=blacklist-hw-watchdog
+pkgdesc="blacklist following kernel module: iTCO_wdt, sp5100-tco"
+install="archlinux.install"
+pkgver=1
+pkgrel=1
+url="https://aur.archlinux.org/packages/blacklist-hw-watchdog"
+arch=('any')
+license=('GPL3')
+source=('98-blacklist-hw-watchdog.hook'
+ 'blacklist-hw-watchdog.conf')
+sha512sums=('3e77984545ce4568a984e76fc5770af623eeac99655b0ee5bd4b1e33f8f5d95af8d12256e0482cf167cfb4e0710b7c3e170c6eb45a8641a8802c215fcd454bac'
+ '9ccabc32e6ab45c32400df3b5ad359dc91c44e50270b7b80fb486ed2c52b92a51624b9795fc97255994d09b2e8f1783abfc4b7613395805632c3a01d3d9a77f6')
+
+package()
+{
+ cd "${srcdir}"
+
+ install -D -m644 "${srcdir}/blacklist-hw-watchdog.conf" \
+ "${pkgdir}/usr/lib/modprobe.d/blacklist-hw-watchdog.conf"
+
+ install -D -m644 "${srcdir}/98-blacklist-hw-watchdog.hook" \
+ "${pkgdir}/usr/share/libalpm/hooks/98-blacklist-hw-watchdog.hook"
+}