summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRobin Candau2023-05-05 17:02:11 +0200
committerRobin Candau2023-05-05 17:02:11 +0200
commit12fdd6c3a00c3dffbf556808704524b36c280b2d (patch)
treea4c304fdede99c97b6e857f0ebe773bda12b02e7 /PKGBUILD
parent6794b7a91c37b5060882f065aa7366a6255d6908 (diff)
downloadaur-blahaj-git.tar.gz
Correct the depends + define crystal cache dir
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e92da2595144..5b56320aed7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,15 @@
pkgname=blahaj-git
_pkgname="${pkgname%-git}"
pkgver=2.0.1.r16.8a35b5c
-pkgrel=1
+pkgrel=2
pkgdesc="Gay sharks at your local terminal - lolcat-like CLI tool (git version)"
arch=('x86_64')
url="https://blahaj.queer.software"
license=('BSD')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-depends=('crystal' 'shards')
-makedepends=('git')
+depends=('crystal' 'libyaml')
+makedepends=('git' 'shards')
source=("${_pkgname}::git+https://github.com/GeopJr/BLAHAJ.git")
sha256sums=('SKIP')
@@ -22,12 +22,12 @@ pkgver() {
build () {
cd "${_pkgname}"
- make build_mt
+ CRYSTAL_CACHE_DIR=crystal make build_mt
}
check () {
cd "${_pkgname}"
- make test_mt
+ CRYSTAL_CACHE_DIR=crystal make test_mt
}
package() {