summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Vernet2023-12-05 10:43:43 -0600
committerDavid Vernet2023-12-05 10:45:41 -0600
commit1fe390a1075ffc6c68f14b91b922e2966d2c7b62 (patch)
tree7e1e328214f91fea0c0b049bd7270df717fee3b2 /PKGBUILD
downloadaur-blazesym.tar.gz
init: Package blazesyum in the AUR
blazesym is being used internally at Meta, and offers the blazecli rust crate [0] that requires libblazesym.so. Let's offer blazesym through the AUR, until it's rolled into a full arch package. [0]: https://crates.io/crates/blazecli Signed-off-by: David Vernet <void@manifault.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..11bf98e52f80
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: David Vernet <void@manifault.com>
+pkgname=blazesym
+pkgver=0.2.0_alpha.8
+pkgrel=1
+pkgdesc="Blazing fast address symbolization"
+arch=('x86_64')
+url="https://github.com/libbpf/blazesym"
+license=('BSD')
+groups=('linux-tools')
+depends=('glibc' 'libelf' 'zlib' 'rust')
+makedepends=('cargo' 'git')
+source=("https://github.com/libbpf/$pkgname/archive/refs/tags/v${pkgver//_/-}.tar.gz")
+sha256sums=('22ffbfbeaf5579175d6da882c1dec41024213b0c84571935510c2e39b3ea53a2')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver//_/-}"
+ cargo build --release
+ cd -
+}
+
+package() {
+ install -d "${pkgdir}/usr/lib"
+ cp "${srcdir}/${pkgname}-${pkgver//_/-}/target/release/lib${pkgname}.so" ${pkgdir}/usr/lib/
+ cp "${srcdir}/${pkgname}-${pkgver//_/-}/target/release/lib${pkgname}.a" ${pkgdir}/usr/lib/
+}