summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBert Peters2024-03-24 17:33:00 +0100
committerBert Peters2024-03-24 17:33:00 +0100
commit218c71d9a5602f442cd8838f53b8f69a8a919bce (patch)
tree364323cbdd35fe3a507059f099592b49dc8ed723 /PKGBUILD
parent23ef3b324491e568c4cb81e3441dd46f067fa7c8 (diff)
downloadaur-bloaty.tar.gz
upgpkg: bloaty 1.1-3
Fix license record, remove unused !emptydirs, comply with Arch cmake guidelines
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 11 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b79e0a45c62d..49d19e296d88 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,13 @@
# Maintainer: Bert Peters <bert@bertptrs.nl>
pkgname=bloaty
pkgver=1.1
-pkgrel=2
+pkgrel=3
pkgdesc="a size profiler for binaries"
arch=(x86_64)
url="https://github.com/google/bloaty"
-license=('Apache')
+license=('Apache-2.0')
depends=(gcc-libs re2 protobuf capstone abseil-cpp)
makedepends=(cmake)
-options=(!emptydirs)
source=(
"https://github.com/google/bloaty/releases/download/v$pkgver/bloaty-$pkgver.tar.bz2"
"https://src.fedoraproject.org/rpms/bloaty/raw/rawhide/f/bloaty-1.1-absl.patch")
@@ -16,27 +15,25 @@ sha256sums=('a308d8369d5812aba45982e55e7c3db2ea4780b7496a5455792fb3dcba9abd6f'
'96cc0528f6464b03d0e68060ff2d24c36624c7d3991cee142df8d3d27cefeb51')
prepare() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname-$pkgver"
# Abseil compatibility patch borrowed from Fedora
patch -p1 < "../bloaty-1.1-absl.patch"
}
build() {
- cd "$pkgname-$pkgver"
- # Bloaty doesn't allow using an empty build type.
- # Unfortunately, this breaks RELRO, so we need to fix that
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_EXE_LINKER_FLAGS_RELEASE="$LDFLAGS" -Wno-dev .
- make
+ cd "$pkgname-$pkgver"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_EXE_LINKER_FLAGS_RELEASE="$LDFLAGS" -Wno-dev
+ make
}
# Not included in the source tarbal, use the git release instead
# check() {
-# cd "$pkgname-$pkgver"
-# make test
+# cd "$pkgname-$pkgver"
+# make test
# }
package() {
- cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
}