summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuca Weiss2021-01-16 22:57:21 +0100
committerLuca Weiss2021-01-16 22:57:21 +0100
commitd63bdbd074edce9a08077a228b2431c6f2a75f53 (patch)
tree2ea60d8a5b624347a811d8301edc30511016db5c /PKGBUILD
parentb05c181065260b53e1eb9324a346b1919cbba0d3 (diff)
downloadaur-blobby-volley-svn.tar.gz
blobby-volley-svn: fix bots, add provides/conflicts
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 39afd87a2cab..286b5034b45a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,15 @@
pkgname=blobby-volley-svn
pkgver=r1681
-pkgrel=2
+pkgrel=3
pkgdesc="Official continuation of the famous Blobby Volley 1.x arcade game"
arch=('x86_64' 'i686')
url="https://sourceforge.net/projects/blobby/"
makedepends=('subversion' 'boost' 'cmake' 'zip')
depends=('physfs' 'sdl2')
license=('GPL')
+provides=('blobby2')
+conflicts=('blobby2')
source=("blobby-code::svn+https://svn.code.sf.net/p/blobby/code/trunk"
"blobby2.desktop"
"blobby2.png"
@@ -42,6 +44,10 @@ package() {
cd blobby-code
make DESTDIR="$pkgdir/" install
+ install -Dm644 data/api.lua "$pkgdir"/usr/share/blobby/api.lua
+ install -Dm644 data/bot_api.lua "$pkgdir"/usr/share/blobby/bot_api.lua
+ install -Dm644 data/rules_api.lua "$pkgdir"/usr/share/blobby/rules_api.lua
+
# install .desktop file and icon
install -dm755 "$pkgdir"/usr/share/{applications,pixmaps}
install -m644 "$srcdir"/blobby2.desktop "$pkgdir"/usr/share/applications