summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrederik Leonhardt2024-04-06 16:54:05 +1300
committerFrederik Leonhardt2024-04-06 16:54:05 +1300
commitcfc5f0cc718fc95e74f0e2b86496808a2a5d3f62 (patch)
treede56ef87ea22765069d159bab75686e4053794fc /PKGBUILD
downloadaur-bluebrick-extras-lgauge.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..448e105640b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Frederik Leonhardt <frederik at leonhardt dot co dot nz>
+pkgname=bluebrick-extras-lgauge
+pkgver=1.2
+pkgrel=1
+pkgdesc="BlueBrick Lego Layout Planer - L-Gauge Extra Parts"
+arch=('any')
+url="https://l-gauge.org/wiki/index.php/CAD_Tools"
+license=('unknown')
+depends=('bluebrick')
+source=("http://l-gauge.org/downloads/SchematicRCv.1.2.zip"
+ "http://l-gauge.org/downloads/Schematic9Vv.1.2.zip")
+sha256sums=('bfecc1e16cf31a461c04f08b31e89585bc93f63aab2e3a9682c62d72f70a6979'
+ '1e8c50cc581de7f30fb32fc0b8f8357eb41a6edcf70d0bff58632c50a8e2f714')
+
+package() {
+ local partsdir='/opt/bluebrick/parts/'
+
+ install -Ddm757 "$pkgdir/$partsdir"
+
+ # RC schematics
+ install -d "$pkgdir/$partsdir/Schematic RC/"
+ find "$srcdir" -maxdepth 1 -type f -name "*RC*" \
+ -exec install -m 644 -D {} "$pkgdir/$partsdir/Schematic RC/" \;
+
+ # 9V schematics
+ install -d "$pkgdir/$partsdir/Schematic 9V/"
+ find "$srcdir" -maxdepth 1 -type f -name "*9V*" \
+ -exec install -m 644 -D {} "$pkgdir/$partsdir/Schematic 9V/" \;
+}
+