summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRafael Silva2024-01-12 16:24:31 +0000
committerRafael Silva2024-01-12 16:56:55 +0000
commit5a98741a146f26288f6f2e59ec4fa79f619b4cae (patch)
tree25438a03a17504946542da610a7befbfb70f8209 /PKGBUILD
parent9716699a30278df6a71d25a3331959ff2b0a06e2 (diff)
downloadaur-bmputil-git.tar.gz
version bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 44fd0329708f..56ff53e8207a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname='bmputil'
pkgname="${_pkgname}-git"
-pkgver=r83.e197489
+pkgver=r85.108bf36
pkgrel=1
pkgdesc='A management utility for debuggers running the Black Magic Debug firmware'
arch=('any')
@@ -11,7 +11,7 @@ conflicts=("${_pkgname}")
provides=("${_pkgname}")
license=('MIT OR Apache-2.0')
makedepends=('git' 'rust' 'cargo')
-source=("git+https://github.com/blackmagic-debug/bmputil.git")
+source=("git+${url}.git")
b2sums=('SKIP')
pkgver() {
@@ -24,7 +24,8 @@ prepare() {
cd "${_pkgname}"
export RUSTUP_TOOLCHAIN=stable
- cargo fetch --locked --target "${CARCH}-unknown-linux-gnu"
+ # No '--locked' flag because this is a git package, it might *need* to be updated
+ cargo fetch --target "$(rustc -vV | sed -n 's/host: //p')"
}
build() {