summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfossdd2021-04-22 15:03:38 +0100
committerfossdd2021-04-22 15:03:38 +0100
commit97060d176c83bdb73ff0fbef76056f08aad6dca0 (patch)
tree583167c0a1499f4a5bc8c5866de37d7d528f081b /PKGBUILD
downloadaur-boa-git.tar.gz
initial boa-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0fbe692ab341
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: fossdd <fossdd@tutanota.com>
+pkgname=boa-git
+_pkgname=boa
+pkgver=v0.11.r103.gbd199677a
+pkgrel=1
+pkgdesc=" Boa is an embeddable and experimental Javascript engine written in Rust. Currently, it has support for some of the language. "
+arch=('i686' 'x86_64')
+url="https://github.com/boa-dev/boa"
+license=(MIT)
+makedepends=('rust' 'git')
+source=('git+https://github.com/boa-dev/boa.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ ( set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd ${_pkgname}
+ cargo build --release
+}
+
+package() {
+ cd ${_pkgname}
+ install -Dm755 target/release/${_pkgname} -t "${pkgdir}"/usr/bin/
+}
+