summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWill Price2016-09-11 23:34:50 +0100
committerWill Price2016-09-11 23:34:50 +0100
commita994235ffe83767476851c0ab2918a5cf8652d11 (patch)
treec2bcc7354d2e68bc20ea3f495f9c18604f844b7b /PKGBUILD
parent8459d7610aa4d0108b50a771e8e695238a83016a (diff)
downloadaur-boot-vhdl-git.tar.gz
Update repository to point to github mirror
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 13 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 39437b91af94..ff70bc7fcb3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,25 @@
# Maintainer: Will Price <will.price94+aur@gmail.com>
pkgname=boot-vhdl-git
-pkgver=4.5
+pkgver=r48.883635b
pkgrel=1
pkgdesc="A VHDL simulator and synthesizer"
arch=('i686' 'x86_64')
license=('GPL')
-url="https://code.google.com/p/boot-vhdl/"
-depends=('python2' 'ghdl' 'pywebkitgtk' 'python2-mechanize'
-'python2-pygments')
-source=('boot-vhdl::git+https://code.google.com/p/boot-vhdl/')
+url="http://freerangefactory.org/boot.html"
+depends=('python2'
+ 'ghdl'
+ 'pywebkitgtk'
+ 'python2-mechanize'
+ 'python2-pygments')
+source=('boot-vhdl::git+https://github.com/willprice/boot.git')
md5sums=('SKIP')
+pkgver() {
+ cd "${pkgname%%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
prepare() {
_fix_python_invocations
}