summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPBS2023-10-04 18:06:41 +0900
committerPBS2023-10-04 18:06:41 +0900
commit91b9264839d666a9f4f4cab00f6c1162b5bde802 (patch)
treec29d86e0e406139a49d3b4e2d9daf0cecb56bcd5 /PKGBUILD
parent35492c1238bed0e07676698dcf35ce662500a672 (diff)
downloadaur-bootmap.tar.gz
Version 0.9.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 4 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7fb0d0967b3d..956d98a2c84d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: PBS <pbs3141 at gmail dot com>
pkgname=bootmap
-pkgver=0.9.2
+pkgver=0.9.3
pkgrel=1
pkgdesc="Integrated EFI image generator and system snapshotter"
arch=('x86_64')
url="https://gitlab.com/pbs3141/$pkgname"
license=('GPL3')
-depends=('gcc-libs' 'util-linux-libs' 'libpipeline' 'libinih' 'btrfs-progs' 'bash' 'perl' 'sbsigntools' 'systemd')
+depends=('gcc-libs' 'util-linux-libs' 'libpipeline' 'libinih' 'btrfs-progs' 'bash' 'perl' 'sbsigntools' 'systemd' 'systemd-ukify')
makedepends=('asciidoc')
source=("$url/-/archive/$pkgver/$pkgname-$pkgver.tar.gz")
-sha256sums=('2cf9ff13e131ccc1c2af9f50b83fe9356aeb2e03736844e19ead90137b9c4cad')
+sha256sums=('8962a71dbb1444f8b6293c997d4f29ff7b552991ace3b290ba7a36ea70d713ae')
backup=('etc/bootmap.conf' 'etc/kernel/cmdline')
build() {
@@ -19,11 +19,5 @@ build() {
package() {
cd "$srcdir/$pkgname-$pkgver"
- install -Dm755 -t "$pkgdir/usr/bin" src/bootmap
- install -Dm644 -t "$pkgdir/etc" conf/bootmap.conf
- install -Dm644 -t "$pkgdir/etc/kernel" conf/cmdline
- install -Dm755 -t "$pkgdir/usr/lib/bootmap" scripts/*
- install -Dm644 -t "$pkgdir/usr/share/libalpm/hooks" hooks/*
- install -Dm644 -t "$pkgdir/usr/share/man/man8" doc/bootmap.8
- install -Dm644 -t "$pkgdir/usr/share/bash-completion/completions" bash-completion/bootmap
+ make DESTDIR="$pkgdir" install
}