summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoan Figueras2020-10-03 09:13:35 +0200
committerJoan Figueras2020-10-03 09:13:35 +0200
commitb5418543b8d35e01f8919a38c6b3d5e45d52b218 (patch)
tree013bec12b00f4ac6e7ad64cebc9082b37c3ddfe3 /PKGBUILD
parent21817a97d970beaf81d8ff8062505085e2c18632 (diff)
downloadaur-b5418543b8d35e01f8919a38c6b3d5e45d52b218.tar.gz
Enabled custom build patch. Thanks Jacek
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9fb0bdc86d32..9cbe7535cabb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,7 +29,7 @@ fi
_reponame=brave-browser
pkgname=brave
pkgver=1.14.84
-pkgrel=1
+pkgrel=2
pkgdesc='A web browser that stops ads and trackers by default'
arch=('x86_64')
url='https://www.brave.com/download'
@@ -48,7 +48,8 @@ patchset_name="chromium-${chromium_base_ver}-patchset-${patchset}"
source=("git+https://github.com/brave/brave-browser.git#tag=v${pkgver}"
'brave-launcher'
'brave-browser.desktop'
- "https://github.com/stha09/chromium-patches/releases/download/${patchset_name}/${patchset_name}.tar.xz")
+ "https://github.com/stha09/chromium-patches/releases/download/${patchset_name}/${patchset_name}.tar.xz"
+ 'brave-custom-build.patch')
arch_revision=51efcaea600acd0648cb70730911f64f332feb95
for Patches in \
chromium-fix-vaapi-on-intel.patch \
@@ -65,6 +66,7 @@ sha256sums=('SKIP'
'725e2d0c32da4b3de2c27a02abaf2f5acca7a25dcea563ae458c537ac4ffc4d5'
'fa6ed4341e5fc092703535b8becaa3743cb33c72f683ef450edd3ef66f70d42d'
'2194fe22b9e5ccdc4a86da4e3572214f670c561486671f57c90636fd3cbfa43e'
+ 'c5ebde144e4f31ce5e6a37aa6a6233489b6b40b03464b9d6077c777f5ad14ac1'
'e495f2477091557b15bff2c99831e0a3db64ea2ebde7dcb22857a6469c944b9a'
'0f041d655335cd2a4773ae7ca5e301a0ff12c6c53f57b7cf6651c268e0420a1c'
'771292942c0901092a402cc60ee883877a99fb804cb54d568c8c6c94565a48e1')
@@ -147,7 +149,7 @@ prepare() {
msg2 "Add patches for custom build"
local _patch
- for _patch in "$srcdir/patches"/*.patch; do
+ for _patch in "$srcdir/brave-custom-build.patch" "$srcdir/patches"/*.patch; do
patch -Np1 -i "$_patch"
done