summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFigue2021-03-04 20:25:21 +0100
committerFigue2021-03-04 20:25:21 +0100
commitba3da602ed28b59ef692544187cb1aab241e8120 (patch)
tree7f5a6b538ba6c429923caa90847bcfece5819c85 /PKGBUILD
parentff9f9974339c108a8367fd880bc086144f825369 (diff)
downloadaur-ba3da602ed28b59ef692544187cb1aab241e8120.tar.gz
1.21.73
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD52
1 files changed, 31 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9969b2bbe5f9..d346e43e501d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,21 +27,21 @@ fi
##
pkgname=brave
-pkgver=1.20.110
+pkgver=1.21.73
pkgrel=1
pkgdesc='A web browser that stops ads and trackers by default'
arch=('x86_64')
url='https://www.brave.com/download'
license=('custom')
depends=('gtk3' 'nss' 'alsa-lib' 'libxss' 'ttf-font' 'libva' 'json-glib')
-makedepends=('git' 'npm<7.0.0' 'python' 'python2' 'icu' 'glibc' 'gperf' 'java-runtime-headless' 'clang' 'python2-setuptools')
+makedepends=('git' 'npm' 'python' 'python2' 'icu' 'glibc' 'gperf' 'java-runtime-headless' 'clang' 'python2-setuptools' 'pipewire')
optdepends=('cups: Printer support'
- 'libpipewire02: WebRTC desktop sharing under Wayland'
+ 'pipewire: WebRTC desktop sharing under Wayland'
'org.freedesktop.secrets: password storage backend on GNOME / Xfce'
'kwallet: for storing passwords in KWallet on KDE desktops'
'sccache: For faster builds')
-chromium_base_ver="88"
-patchset="3"
+chromium_base_ver="89"
+patchset="7"
patchset_name="chromium-${chromium_base_ver}-patchset-${patchset}"
_launcher_ver=6
source=("brave-browser::git+https://github.com/brave/brave-browser.git#tag=v${pkgver}"
@@ -54,10 +54,12 @@ source=("brave-browser::git+https://github.com/brave/brave-browser.git#tag=v${pk
"chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz"
"https://github.com/stha09/chromium-patches/releases/download/${patchset_name}/${patchset_name}.tar.xz"
"chromium-no-history.patch" "chromium-no-history2.patch")
-arch_revision=bbf06a92e65eeccade2e484562ecd81b89756df0
+arch_revision=3a82378691710ede4ec4ea7a701773747767d41c
for Patches in \
- subpixel-anti-aliasing-in-FreeType-2.8.1.patch \
- chromium-glibc-2.33.patch
+ add-dependency-on-opus-in-webcodecs.patch \
+ add-ctime-for-std-time.patch \
+ chromium-glibc-2.33.patch \
+ use-oauth2-client-switches-as-default.patch
do
source+=("${Patches}::https://git.archlinux.org/svntogit/packages.git/plain/trunk/${Patches}?h=packages/chromium&id=${arch_revision}")
done
@@ -70,11 +72,13 @@ sha256sums=('SKIP'
'725e2d0c32da4b3de2c27a02abaf2f5acca7a25dcea563ae458c537ac4ffc4d5'
'fa6ed4341e5fc092703535b8becaa3743cb33c72f683ef450edd3ef66f70d42d'
'04917e3cd4307d8e31bfb0027a5dce6d086edb10ff8a716024fbb8bb0c7dccf1'
- 'e5a60a4c9d0544d3321cc241b4c7bd4adb0a885f090c6c6c21581eac8e3b4ba9'
+ 'f8b1558f6c87b33423da854d42f0f69d47885a96d6bf6ce7f26373e93d47442f'
'ea3446500d22904493f41be69e54557e984a809213df56f3cdf63178d2afb49e'
'd7775ffcfc25eace81b3e8db23d62562afb3dbb5904d3cbce2081f3fe1b3067d'
- '1e2913e21c491d546e05f9b4edf5a6c7a22d89ed0b36ef692ca6272bcd5faec6'
- '2fccecdcd4509d4c36af873988ca9dbcba7fdb95122894a9fdf502c33a1d7a4b')
+ 'b86b11de8db438c47f0a84c7956740f648d21035f4ee46bfbd50c3348d369121'
+ '102e0c976c0d7fd1fbe2f2978ec621499a97b62457b3fde4daf84f026d1a53a7'
+ '2fccecdcd4509d4c36af873988ca9dbcba7fdb95122894a9fdf502c33a1d7a4b'
+ 'e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711')
# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
# Keys are the names in the above script; values are the dependencies in Arch
@@ -103,7 +107,7 @@ _unwanted_bundled_libs=(
# Add depends if user wants a release with custom cflags and system libs
if [ "$COMPONENT" = "4" ]; then
- #echo "Build with system libs is disabled for now" && exit 1
+ echo "Build with system libs is disabled for now" && exit 1
brave_base_ver="$(echo $pkgver | cut -d . -f 1-2)"
brave_patchset="1"
brave_patchset_name="brave-${brave_base_ver}-patches-${brave_patchset}"
@@ -120,7 +124,6 @@ fi
prepare() {
cd "brave-browser"
-
# Hack to prioritize python2 in PATH
mkdir -p "${srcdir}/bin"
ln -sf /usr/bin/python2 "${srcdir}/bin/python"
@@ -132,8 +135,9 @@ prepare() {
patch -Np1 -i ../chromium-no-history.patch
git submodule init
- git config submodule.depot_tools.url "${srcdir}"/depot_tools
+ git config submodule.chromium.url "${srcdir}"/chromium
git config submodule.brave-core.url "${srcdir}"/brave
+ git config submodule.depot_tools.url "${srcdir}"/depot_tools
git config submodule.adblock-rust.url "${srcdir}"/adblock-rust
git submodule update
cp -rT "${srcdir}"/chromium src
@@ -141,7 +145,7 @@ prepare() {
cp -r "${srcdir}"/depot_tools src/brave/vendor/
cp -rT "${srcdir}"/adblock-rust src/brave/vendor/adblock_rust_ffi
- patch -Np1 -i ../chromium-no-history2.patch
+ #patch -Np1 -i ../chromium-no-history2.patch
msg2 "Running \"npm run\""
if [ -d src/out/Release ]; then
@@ -160,14 +164,20 @@ prepare() {
third_party/libxml/chromium/*.cc
# Upstream fixes
- patch -Np1 -d third_party/skia <../../subpixel-anti-aliasing-in-FreeType-2.8.1.patch
+ # Use the --oauth2-client-id= and --oauth2-client-secret= switches for
+ # setting GOOGLE_DEFAULT_CLIENT_ID and GOOGLE_DEFAULT_CLIENT_SECRET at
+ # runtime -- this allows signing into Chromium without baked-in values
+ patch -Np1 -i ../../use-oauth2-client-switches-as-default.patch
+
+ # https://crbug.com/1164975
patch -Np1 -i ../../chromium-glibc-2.33.patch
+ # Upstream fixes
+ patch -Np1 -i ../../add-dependency-on-opus-in-webcodecs.patch
+ patch -Np1 -i ../../add-ctime-for-std-time.patch
+
# Fixes for building with libstdc++ instead of libc++
- patch -Np1 -i ../../patches/chromium-87-openscreen-include.patch
- patch -Np1 -i ../../patches/chromium-88-CompositorFrameReporter-dcheck.patch
- patch -Np1 -i ../../patches/chromium-88-ideographicSpaceCharacter.patch
- patch -Np1 -i ../../patches/chromium-88-AXTreeFormatter-include.patch
+ patch -Np1 -i ../../patches/chromium-89-quiche-dcheck.patch
# Force script incompatible with Python 3 to use /usr/bin/python2
sed -i '1s|python$|&2|' third_party/dom_distiller_js/protoc_plugins/*.py
@@ -198,7 +208,7 @@ prepare() {
-delete
done
- python2 build/linux/unbundle/replace_gn_files.py \
+ ./build/linux/unbundle/replace_gn_files.py \
--system-libraries "${!_system_libs[@]}"
fi
}