summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartin Rodriguez Reboredo2023-06-03 10:29:15 -0300
committerCaleb Maclennan2023-06-13 08:03:35 +0300
commitddc12c2922789d0e2e1d5435f8ecb16a9902aefd (patch)
tree5a4e4e88be0733eea49a5a3124833f783834ef76 /PKGBUILD
parent3aa560b4ef5d5edadaebc5ad4d5b1a454ddaf15a (diff)
downloadaur-ddc12c2922789d0e2e1d5435f8ecb16a9902aefd.tar.gz
uppkg: brave 1.52.117
upstream release Signed-off-by: Martin Rodriguez Reboredo <yakoyoku@gmail.com> Signed-off-by: Caleb Maclennan <caleb@alerque.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD86
1 files changed, 42 insertions, 44 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dd312e38fa86..6c710e0ea00d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,7 +28,7 @@
: "${COMPONENT:=4}"
pkgname=brave
-pkgver=1.49.128
+pkgver=1.52.117
pkgrel=1
pkgdesc='Web browser that blocks ads and trackers by default'
arch=(x86_64)
@@ -46,7 +46,7 @@ optdepends=('pipewire: WebRTC desktop sharing under Wayland'
'org.freedesktop.secrets: password storage backend on GNOME / Xfce'
'kwallet: support for storing passwords in KWallet on Plasma')
options=('!lto') # Chromium adds its own flags for ThinLTO
-_chromium_ver=111.0.5563.110
+_chromium_ver=114.0.5735.90
_gcc_patchset=2
_patchset_name="chromium-${_chromium_ver%%.*}-patchset-$_gcc_patchset"
_launcher_ver=8
@@ -55,45 +55,41 @@ source=("brave-browser::git+https://github.com/brave/brave-browser.git#tag=v$pkg
"chromium::git+https://chromium.googlesource.com/chromium/src.git#tag=$_chromium_ver"
'depot_tools::git+https://chromium.googlesource.com/chromium/tools/depot_tools.git'
"https://github.com/foutrelis/chromium-launcher/archive/refs/tags/v$_launcher_ver/chromium-launcher-$_launcher_ver.tar.gz"
- "https://github.com/stha09/chromium-patches/releases/download/$_patchset_name/$_patchset_name.tar.xz"
chromium-launcher-electron-app.patch
chromium-launcher-vendor.patch
system-rust-utils.patch
- brave-1.11-bat-native-ledger-header_fix-ctime.patch
brave-1.19-BUILD.gn.patch
- brave-1.43-bat-native-ads-hash_vectorizer_fix-cstring.patch
- brave-1.43-bat-native-ads-vector_data_fix-cmath.patch
- brave-1.43-bitcoin-core_remove-serialize.h.patch
brave-1.43-debounce-debounce_navigation_throttle_fix.patch
brave-1.43-ntp_background_images-std-size_t.patch
- brave-1.48-partitioned_host_state_map-cstring.patch
- brave-1.49-brave_wallet-hd_key-vector_fix.patch)
-_arch_revision=c762dd2d9d0eaa900772315d57bb5ed7dfdf895d
-_patches=(sql-relax-constraints-on-VirtualCursor-layout.patch
+ brave-1.48-partitioned_host_state_map-cstring.patch)
+_arch_revision=fa08adba87b6222bdf9ba31aaa41579e634ec444
+_patches=(add-some-typename-s-that-are-required-in-C-17.patch
+ REVERT-disable-autoupgrading-debug-info.patch
+ download-bubble-typename.patch
+ webauthn-variant.patch
+ random-fixes-for-gcc13.patch
disable-GlobalMediaControlsCastStartStop.patch
use-oauth2-client-switches-as-default.patch)
for _patch in "${_patches[@]}"; do
- source+=("https://raw.githubusercontent.com/archlinux/svntogit-packages/$_arch_revision/trunk/$_patch")
+ source+=("https://gitlab.archlinux.org/archlinux/packaging/packages/chromium/-/raw/$_arch_revision/$_patch")
done
sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'213e50f48b67feb4441078d50b0fd431df34323be15be97c55302d3fdac4483a'
- 'a016588340f1559198e4ce61c6e91c48cf863600f415cb5c46322de7e1f77909'
'9235485adc4acbfaf303605f4428a6995a7b0b3b5a95181b185afbcb9f1f6ae5'
'404bf09df39310a1e374c5e7eb9c7311239798adf4e8cd85b7ff04fc79647f88'
- 'a8b119138c7157a71f2d1240bea5a2af9593d6b774586f5cc337b344cd9a18b8'
- '1f7c9e7f15876bf3a6611971dc10ad0311fdcc92bc4d369ff077c984b395b802'
+ '579c5cf5cd59c89ac363f0adcf42463a4aa2effb30fbf09467d4745bf26c2e7d'
'12a3d37ffca4c0fa25f89f02efdf79d24f6412ee29ec35e8a00f9086dba4e822'
- 'a4ed0ad8f4931bae08c42a20266b8e2f934f21811fe0892960798f14a1fcfd0b'
- '5c1e562b25d4fe614f3a77e00accc53001541b7b3f308fb7512cce1138878d7e'
- '0b5764355b9201d201b1e08f700bbb5a7fa238bef127b95d36cbf8ce2afa73a6'
'30a6a9ca2a6dd965cb2d9f02639079130948bf45d483f0c629f2cf8394a1c22f'
'ea0cd714ccaa839baf7c71e9077264016aa19415600f16b77d5398fd49f5a70b'
'3864fcb12aaec849fd0e5423c9c5dfb1fdd7805e298a52125776bb24abe71e3c'
- 'f55438b4d5fd3c14e3e6c16383e6305ec52818c1fc9438d0d40ff72d157504a3'
- 'e66be069d932fe18811e789c57b96249b7250257ff91a3d82d15e2a7283891b7'
+ '621ed210d75d0e846192c1571bb30db988721224a41572c27769c0288d361c11'
+ '1b782b0f6d4f645e4e0daa8a4852d63f0c972aa0473319216ff04613a0592a69'
+ 'd464eed4be4e9bf6187b4c40a759c523b7befefa25ba34ad6401b2a07649ca2a'
+ '590fabbb26270947cb477378b53a9dcd17855739076b4af9983e1e54dfcab6d7'
+ 'ba4dd0a25a4fc3267ed19ccb39f28b28176ca3f97f53a4e9f5e9215280040ea0'
'7f3b1b22d6a271431c1f9fc92b6eb49c6d80b8b3f868bdee07a6a1a16630a302'
'e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711')
@@ -109,7 +105,7 @@ declare -gA _system_libs=(
[harfbuzz-ng]=harfbuzz
[icu]=icu
[jsoncpp]=jsoncpp
- [libaom]=aom
+ #[libaom]=aom # https://aomedia.googlesource.com/aom/+/706ee36dcc82
#[libavif]=libavif # https://github.com/AOMediaCodec/libavif/commit/4d2776a3
[libdrm]=
[libjpeg]=libjpeg
@@ -127,9 +123,7 @@ declare -gA _system_libs=(
_unwanted_bundled_libs=(
"$(printf "%s\n" ${!_system_libs[@]} | sed 's/^libjpeg$/&_turbo/')"
)
-for _dep in "${_system_libs[@]}"; do
- depends+=($_dep)
-done
+depends+=(${_system_libs[@]})
prepare() {
cd chromium-launcher-$_launcher_ver
@@ -190,7 +184,8 @@ prepare() {
--local_state=src/chrome/android/profiles/local.txt \
--output_name=src/chrome/android/profiles/afdo.prof \
--gs_url_base=chromeos-prebuilt/afdo-job/llvm
- # ln -s /usr/bin/java third_party/jdk/current/bin
+ mkdir -p third_party/jdk/current/bin
+ ln -s /usr/bin/java third_party/jdk/current/bin
# Brave specific hooks
cd src/brave
@@ -218,13 +213,19 @@ prepare() {
patch -Np1 -i "${srcdir}/use-oauth2-client-switches-as-default.patch"
# Upstream fixes
- patch -Np1 -i "${srcdir}/sql-relax-constraints-on-VirtualCursor-layout.patch"
+ patch -Np1 -i "${srcdir}/add-some-typename-s-that-are-required-in-C-17.patch"
+
+ # Revert addition of compiler flag that needs newer clang
+ patch -Rp1 -i "${srcdir}/REVERT-disable-autoupgrading-debug-info.patch"
# Disable kGlobalMediaControlsCastStartStop by default
# https://crbug.com/1314342
patch -Np1 -i "${srcdir}/disable-GlobalMediaControlsCastStartStop.patch"
- # Fixes for building with libstdc++ instead of libc++
+ # Build fixes
+ patch -Np1 -i "${srcdir}/download-bubble-typename.patch"
+ patch -Np1 -i "${srcdir}/webauthn-variant.patch"
+ patch -Np1 -i "${srcdir}/random-fixes-for-gcc13.patch"
# Hacky patching
sed -e 's/\(enable_distro_version_check =\) true/\1 false/g' -i chrome/installer/linux/BUILD.gn
@@ -324,7 +325,6 @@ build() {
'enable_hangout_services_extension=true'
'enable_widevine=true'
'enable_nacl=false'
- #'use_vaapi=true'
)
_flags+=("rustup_path=\"$HOME/.rustup\"" "cargo_path=\"$HOME/.cargo\"")
@@ -370,38 +370,36 @@ build() {
CXXFLAGS=${CXXFLAGS/-Wp,-D_GLIBCXX_ASSERTIONS}
## See explanation on top to select your build
+ local _build_type
case $COMPONENT in
0)
echo "Normal build (with debug)"
- npm run build
- npm run build -- --target chrome_sandbox
- npm run build -- --target chromedriver.unstripped
+ npm_args=()
;;
2)
echo "Static build"
- npm run build Static
- npm run build Static -- --target chrome_sandbox
- npm run build Static -- --target chromedriver.unstripped
+ _build_type=Static
+ npm_args=()
;;
3)
echo "Debug build"
- npm run build Debug
- npm run build Debug -- --target chrome_sandbox
- npm run build Debug -- --target chromedriver.unstripped
+ _build_type=Debug
+ npm_args=()
;;
4)
echo "Release custom build"
- npm run build Release -- "${npm_args[@]}"
- npm run build Release -- --target chrome_sandbox "${npm_args[@]}"
- npm run build Release -- --target chromedriver.unstripped "${npm_args[@]}"
+ _build_type=Release
;;
1|*)
echo "Release build"
- npm run build Release
- npm run build Release -- --target chrome_sandbox
- npm run build Release -- --target chromedriver.unstripped
+ _build_type=Release
+ npm_args=()
;;
esac
+
+ npm run build ${_build_type} -- "${npm_args[@]}"
+ npm run build ${_build_type} -- --target chrome_sandbox "${npm_args[@]}"
+ npm run build ${_build_type} -- --target chromedriver.unstripped "${npm_args[@]}"
}
package() {
@@ -411,7 +409,7 @@ package() {
install -Dm644 LICENSE \
"$pkgdir/usr/share/licenses/$pkgname/LICENSE.launcher"
- install -d -m0755 "$pkgdir/usr/lib/$pkgname/"{,locales,resources}
+ install -dm755 "$pkgdir/usr/lib/$pkgname/"{,locales,resources}
# Copy necessary release files
cd ../brave-browser/src