summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCubeTheThird2021-05-15 13:24:05 -0400
committerCubeTheThird2021-05-15 13:24:05 -0400
commitdb5b9f77ff3f3e58f246284acdce5dfeb6c61e9d (patch)
tree3b2bc2d9c176f42d943714ae8de86aeb06103791 /PKGBUILD
parent7e80be264f355dea910970fe9118eda5f6035a54 (diff)
downloadaur-brogue-ce-git.tar.gz
Fix for invalid pkgver
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 75cfdb25e9bb..b317ee37f3fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
#Maintainer: CubeTheThird <cubethethird@gmail.com>
pkgname=brogue-ce-git
-pkgver=1.9.4.r19.dev.5e87eb6
+pkgver=1.9.4.r106.dev.0ca1176
pkgrel=1
pkgdesc="Brogue Community Edition: A 26-level dungeon crawl to the Amulet of Yendor."
arch=('i686' 'x86_64')
@@ -13,10 +13,11 @@ md5sums=('SKIP')
pkgver() {
cd "$srcdir/$pkgname"
-VER=$(grep "BROGUE_VERSION_STRING" src/brogue/Rogue.h | grep -o '[0-9.]\{1,\}')
+VER=$(grep "BROGUE_DUNGEON_VERSION_STRING" src/brogue/Rogue.h | grep -o '[0-9.]\{1,\}')
+PAT=$(grep "BROGUE_PATCH" src/brogue/Rogue.h | grep -o '[0-9]\{1,\}')
REV="$(git rev-list $(git describe --abbrev=0)..HEAD --count)"
EXT="dev.$(git log -1 --format='%h')"
-echo ${VER}.r${REV}.${EXT}
+echo ${VER}.${PAT}.r${REV}.${EXT}
}
build() {