summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJosé San juan2020-09-23 18:51:16 +0100
committerJosé San juan2020-09-23 18:51:16 +0100
commit75867cda85b96baa45e667dc9c163c61abf07267 (patch)
tree9f88428659502d8b5438e387ea48029aa30bb0d7 /PKGBUILD
parentde766df095bc37425bc72edd7c130110839c4f09 (diff)
downloadaur-brother-dcpj132w.tar.gz
updated package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 13 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 549620e308c5..c68eab118d61 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,32 +3,29 @@
pkgname=brother-dcpj132w
pkgver=3.0.0
-pkgrel=5
+pkgrel=6
pkgdesc="Driver for the Brother DCP-j132w wifi multifuncional printer"
url="http://solutions.brother.com/linux/en_us/index.html"
license=('custom:brother')
depends=('a2ps' 'cups')
arch=('i686' 'x86_64')
install=${pkgname}.install
-md5sums=('c300b0af971adc0da0c7fc475d49bc84'
- 'f297c41bdb7e1e6a98e8729564e58a01'
- 'ca8f119dc59267f4a3ecb78276112057')
+md5sums=('ca8f119dc59267f4a3ecb78276112057'
+ 'f297c41bdb7e1e6a98e8729564e58a01')
source=(
- "./fix_lp.patch" \
- "http://www.brother.com/pub/bsc/linux/dlf/dcpj132wlpr-3.0.0-1.i386.rpm" \
- "http://www.brother.com/pub/bsc/linux/dlf/dcpj132wcupswrapper-3.0.0-1.i386.rpm"
+ "http://www.brother.com/pub/bsc/linux/dlf/dcpj132wcupswrapper-3.0.0-1.i386.rpm" \
+ "http://www.brother.com/pub/bsc/linux/dlf/dcpj132wlpr-3.0.0-1.i386.rpm"
)
-build() {
- cd "$srcdir"
- patch -Np0 < fix_lp.patch
+post_install() {
+ /opt/brother/Printers/dcpj132w/cupswrapper/cupswrapperdcpj132w
}
-package() {
- mkdir -p "$pkgdir/usr/share/cups/model/"
- mkdir -p "$pkgdir/usr/lib/cups/filter/"
- cp "$srcdir/opt/brother/Printers/dcpj132w/cupswrapper/brother_dcpj132w_printer_en.ppd" "$pkgdir/usr/share/cups/model/brother_dcpj132w_printer_en.ppd"
- cp "$srcdir/opt/brother/Printers/dcpj132w/lpd/filterdcpj132w" "$pkgdir/usr/lib/cups/filter/brother_lpdwrapper_dcpj132w"
- cp -r "$srcdir/opt/" "$pkgdir/opt/"
+package()
+{
+ install -d $pkgdir/usr/bin
+ install -d $pkgdir/var/spool/lpd
+ install -Dm755 "$srcdir"/usr/bin/brprintconf_dcpj132w "$pkgdir"/usr/bin/
+ cp -R $srcdir/opt $pkgdir/opt
}