summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChiwan Park2021-08-29 16:10:40 +0900
committerChiwan Park2021-08-29 16:10:40 +0900
commit03fb9edf1440a3cfc8d9a02fcdc75f04b45eb560 (patch)
treee66255e492c268b7e8ca162f54a79d38c0634386 /PKGBUILD
downloadaur-brother-dcpt520w.tar.gz
Initialize commit with package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..60468feca17b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Chiwan Park <chiwanpark@hotmail.com>
+
+pkgname=brother-dcpt520w
+pkgver=3.5.0
+pkgrel=1
+pkgdesc="Driver for the Brother DCP-T520W wifi multifuncional printer"
+url="http://solutions.brother.com/linux/en_us/index.html"
+license=('custom:brother')
+install="brother-dcpt520w.install"
+arch=('i686' 'x86_64')
+optdepends=('sane: scanning support'
+ 'brscan4: making dcpt520w available to sane'
+ 'brscan-skey: scankey support if connected via usb')
+
+if [[ "$CARCH" == "x86_64" ]] ; then
+ depends=('a2ps' 'cups' 'lib32-glibc')
+elif [[ "$CARCH" == "i686" ]] ; then
+ depends=('a2ps' 'cups')
+fi
+
+source=(
+ "http://download.brother.com/welcome/dlf105173/dcpt520wpdrv-$pkgver-$pkgrel.i386.rpm" \
+ "fix_lp.patch"
+)
+sha256sums=(
+ 'f096e7737b985209404d25ae25b862463c07fff67f31f807b68a188209c7b734' \
+ 'db4f8c1f9ad69aa0dbb53755e076ef60256f871f64c4d6179cd9e4d21c4625c1'
+)
+
+build() {
+ cd "$srcdir"
+ patch -Np0 < fix_lp.patch
+}
+
+post_install() {
+ /opt/brother/Printers/dcpt520w/cupswrapper/cupswrapperdcpt520w
+}
+
+package() {
+ install -d $pkgdir/usr/bin
+ install -d $pkgdir/var/spool/lpd
+ cp -R $srcdir/opt $pkgdir/opt
+}