summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkszonek2017-09-07 23:47:15 +0200
committerkszonek2017-09-07 23:47:15 +0200
commitffa90002d1065c41a5789e775c68affd2258f8f0 (patch)
tree3aa7ecb8fec470f9bae5a33b94d8ea82c89840c6 /PKGBUILD
downloadaur-brother-mfc-j200.tar.gz
Initial commit of Brother MFC-J200 package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..02106d5cb50c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: kszonek <aur@kszonek.pl>
+# AUR [brother-mfc-j200] package by kszonek <aur@kszonek.pl>
+# based on brother-mfc-j220 package
+
+pkgname="brother-mfc-j200"
+_model="j200"
+pkgver="3.0.0"
+pkgrel=1
+pkgdesc="LPR and CUPS driver for the Brother MFC-J200"
+url="http://solutions.brother.com/linux/en_us/"
+license=('custom:brother commercial license')
+
+arch=('i686' 'x86_64')
+
+depends=('cups' 'perl' 'bash')
+if test "$CARCH" == x86_64; then
+ depends+=('lib32-glibc')
+fi
+
+install="$pkgname.install"
+
+source=("http://www.brother.com/pub/bsc/linux/dlf/mfcj200lpr-$pkgver-$pkgrel.i386.rpm"
+ "http://www.brother.com/pub/bsc/linux/dlf/mfcj200cupswrapper-$pkgver-$pkgrel.i386.rpm"
+)
+md5sums=('f2e7c9e3515103ebde415662bbfc79e3'
+ 'bcba51ee76ad7e665ee950b8979fb95d'
+)
+
+prepare() {
+ echo "unpacking"
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/bin"
+ install -m 0755 -o root -g root "${srcdir}/usr/bin/brprintconf_mfcj200" "${pkgdir}/usr/bin/brprintconf_mfcj200"
+
+ mkdir -p "${pkgdir}/opt"
+ cp -R "${srcdir}/opt/brother" "${pkgdir}/opt/brother"
+
+ mkdir -p "${pkgdir}/usr/lib/cups/filter"
+ echo "#! /opt/brother/Printers/mfcj200/lpd/filtermfcj200" > "${srcdir}/filter-shim"
+ install -m 0755 -o root -g root "${srcdir}/filter-shim" "${pkgdir}/usr/lib/cups/filter/brother_lpdwrapper_mfcj200"
+
+ mkdir -p "${pkgdir}/usr/share/ppd/cupsfilters"
+ install -m 0644 -o root -g root "${srcdir}/opt/brother/Printers/mfcj200/cupswrapper/brother_mfcj200_printer_en.ppd" "${pkgdir}/usr/share/ppd/cupsfilters"
+}