summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWayne J2019-04-20 15:15:22 +0100
committerWayne J2019-04-20 15:15:22 +0100
commit9c0cf1e62b318c77ef0f4cc94abe1fbcd4c64a8e (patch)
tree966ad4a0563db3547957fb149a35cfadde9b5f49 /PKGBUILD
downloadaur-brother-mfc-j6530dw.tar.gz
Updating the package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cbf0d477889c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Wayne Jones waynej98 <at> gmail.com
+# Contributor: Based on the Brother MFC-J6930DW update package
+pkgname="brother-mfc-j6530dw"
+pkgver="1.0.1"
+pkgrel="0"
+pkgdesc="Brother MFC-J6530DW CUPS driver."
+url="http://support.brother.com/g/b/downloadtop.aspx?c=us&lang=en&prod=mfcj6530dw_us_eu_as"
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('lib32-glibc' 'lib32-libstdc++5' 'cups>=2.1.2' 'ghostscript' )
+source=(
+ "https://download.brother.com/welcome/dlf103007/mfcj6530dwlpr-1.0.1-0.i386.rpm"
+ "https://download.brother.com/welcome/dlf103031/mfcj6530dwcupswrapper-1.0.1-0.i386.rpm"
+)
+md5sums=('51a985d64540af2e0df6343513eb72a6'
+ '0f183df0e9e183d56f51fd3ae4a13299')
+
+package() {
+ mkdir -p "$pkgdir/usr/share/cups/model/"
+ mkdir -p "$pkgdir/usr/lib/cups/filter/"
+
+ ln -s "/opt/brother/Printers/mfcj6530dw/cupswrapper/brother_mfcj6530dw_printer_en.ppd" "$pkgdir/usr/share/cups/model/brother_mfcj6530dw_printer_en.ppd"
+ ln -s "/opt/brother/Printers/mfcj6530dw/cupswrapper/brother_lpdwrapper_mfcj6530dw" "$pkgdir/usr/lib/cups/filter/brother_lpdwrapper_mfcj6530dw"
+ cp -r "$srcdir/opt/" "$pkgdir/opt/"
+}