summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorblat2016-03-17 09:23:07 +0100
committerblat2016-03-17 09:23:07 +0100
commit78a9a5487a41f3826b9ceeaa9c7b355b4782d3cc (patch)
treeade03830d9bcbdcf16644302efdc73b5fc472b2a /PKGBUILD
downloadaur-brother-mfc-j680dw.tar.gz
brother-mfc-j680dw-1.0.0-0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD61
1 files changed, 61 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..49dbb990d682
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: Mickael Blatiere <blatiere@gmail.com>
+# Based on package brother-mfc-j480dw by Eric Lehmann <katyl@katyl.info> and Peter Vasil <mail@petervasil.net>
+pkgname="brother-mfc-j680dw"
+pkgver="1.0.0"
+pkgrel=0
+pkgdesc="LPR and CUPS driver for the Brother MFC-J680DW"
+url="http://solutions.brother.com/linux/en_us/"
+arch=("i686" "x86_64")
+license=('custom:brother commercial license')
+depends=("cups")
+install="$pkgname.install"
+source=(
+ "http://download.brother.com/welcome/dlf102074/mfcj680dwlpr-${pkgver}-${pkgrel}.i386.rpm"
+ "http://download.brother.com/welcome/dlf102075/mfcj680dwcupswrapper-${pkgver}-${pkgrel}.i386.rpm"
+ 'cupswrapper-license.txt'
+ 'lpr-license.txt'
+)
+md5sums=('69164d81aa85ed185b5779b4f6bbf2ce'
+ '1cde7bf3a92cca440d3d56dbde5dcfa4'
+ '97ad0cffd216059e9d1d3121899d8646'
+ '5e87a3dc0f3e3438c088eda0f3565f0d')
+if test "$CARCH" == x86_64; then
+ depends+=('lib32-glibc')
+fi
+prepare() {
+ # do not install in '/usr/local'
+ if [ -d $srcdir/usr/local/Brother ]; then
+ install -d $srcdir/usr/share
+ mv $srcdir/usr/local/Brother/ $srcdir/usr/share/brother
+ rm -rf $srcdir/usr/local
+ sed -i 's|/usr/local/Brother|/usr/share/brother|g' `grep -lr '/usr/local/Brother' ./`
+ fi
+ # setup cups-directories
+ install -d $srcdir/usr/share/cups/model
+ install -d $srcdir/usr/lib/cups/filter
+ # go to the cupswrapper directory and find the source file from wich to generate a ppd- and wrapper-file
+ cd `find . -type d -name 'cupswrapper'`
+ if [ -f cupswrapper* ]; then
+ _wrapper_source=`ls cupswrapper*`
+ sed -i '/^\/etc\/init.d\/cups/d' $_wrapper_source
+ sed -i '/^sleep/d' $_wrapper_source
+ sed -i '/^lpadmin/d' $_wrapper_source
+ sed -i 's|/usr|$srcdir/usr|g' $_wrapper_source
+ sed -i 's|/opt|$srcdir/opt|g' $_wrapper_source
+ sed -i 's|/model/Brother|/model|g' $_wrapper_source
+ sed -i 's|lpinfo|echo|g' $_wrapper_source
+ export srcdir=$srcdir
+ ./$_wrapper_source
+ sed -i 's|$srcdir||' $srcdir/usr/lib/cups/filter/*lpdwrapper*
+ sed -i "s|$srcdir||" $srcdir/usr/lib/cups/filter/*lpdwrapper*
+ rm $_wrapper_source
+ fi
+ # /etc/printcap is managed by cups
+ rm `find $srcdir -type f -name 'setupPrintcap*'`
+}
+package() {
+ cp -R $srcdir/usr $pkgdir
+ if [ -d $srcdir/opt ]; then cp -R $srcdir/opt $pkgdir; fi
+ install -m 644 -D cupswrapper-license.txt $pkgdir/usr/share/licenses/${pkgname}/cupswrapper-licence.txt
+ install -m 644 -D lpr-license.txt $pkgdir/usr/share/licenses/${pkgname}/lpr-licence.txt
+}