summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2020-08-25 01:27:46 +0200
committerChristopher Arndt2020-08-25 01:27:46 +0200
commit9137c29fffb3a4badf95753c55232ec04a8b93e8 (patch)
treef4797f7195009583789b1a1924615a95515d4305 /PKGBUILD
parentf232c530c02fc02b95dd18ded08631f7e70cabeb (diff)
downloadaur-bslizr-git.tar.gz
Various PKGBUILD improvements as for other B.* packages
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD68
1 files changed, 32 insertions, 36 deletions
diff --git a/PKGBUILD b/PKGBUILD
index edcef1b4ec91..ba93d3783dcf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,53 +1,49 @@
# Maintainer: Milk Brewster (milk on freenode irc)
-pkgname=bslizr-git
-pkgver=r126.bed9c29
+# Contributor: Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+_name="BSlizr"
+_pkgname="${_name,,}"
+_plugin_uri="https://www.jahnichen.de/plugins/lv2/${_name}"
+pkgname="${_pkgname}-git"
+pkgdesc="Sequenced audio slicing effect LV2 plugin (git version)"
+pkgver=1.2.8.r0.gf988a45
pkgrel=1
-epoch=
-pkgdesc="Sequenced audio slicing effect LV2 plugin with a step sequencer effect. "
arch=('x86_64')
-url="https://github.com/sjaehn/BSlizr"
-license=('GPL')
-groups=()
-depends=('xorg-server' 'cairo' 'lv2')
-makedepends=()
-checkdepends=()
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
-source=("git+https://github.com/sjaehn/BSlizr")
-noextract=()
+url="https://github.com/sjaehn/${_name}"
+license=('GPL3')
+groups=('lv2-plugins' 'pro-audio')
+depends=('cairo' 'gcc-libs' 'glibc' 'libx11')
+makedepends=('git' 'lv2')
+checkdepends=('lv2lint')
+provides=("${_pkgname}" "${_pkgname}=${pkgver//.r*/}")
+conflicts=("${_pkgname}")
+source=("${_pkgname}::git+https://github.com/sjaehn/${_name}")
md5sums=('SKIP')
-validpgpkeys=()
-# prepare() {
-# }
pkgver() {
- cd "$srcdir"/BSlizr
+ cd "${srcdir}/${_pkgname}"
( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ git describe --long --tags 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
)
- }
-
+}
build() {
- cd "$srcdir"/BSlizr
+ cd "${srcdir}/${_pkgname}"
make
}
-
-# check() {
- # cd "$pkgname-$pkgver"
- # make -k check
-# }
+
+check() {
+ cd "${srcdir}/${_pkgname}"
+ # TTL has no minor/microVersion yet, so skip tests for these until first release
+ lv2lint -t "Plugin Version *" -Mpack -I "${_name}.lv2/" "${_plugin_uri}"
+}
package() {
- cd "$srcdir"/BSlizr
- # make INSTALL_DIR="${pkgdir}/usr/lib/lv2" install
- make PREFIX="${pkgdir}/usr" install
+ cd "${srcdir}/${_pkgname}"
+ make PREFIX="/usr" DESTDIR="$pkgdir/" install
+ install -vDm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+ # remove useless license file
+ find "${pkgdir}/usr/lib/" -type f -iname "*LICENSE*" -delete
}