summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwillemw122024-02-14 15:26:03 +0100
committerwillemw122024-02-14 15:26:03 +0100
commit58554f639ebc6880ec8320dec782d270a7b8a585 (patch)
treefe638506f69b27b5bf276212ca1dd01af613cd89 /PKGBUILD
parent1ee3fb80df63d537c1499a1e6c95e4c83e94eec0 (diff)
downloadaur-btrfs-backup-git.tar.gz
Set "target" inside package source folder
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c27d89cd9086..30dade8f078b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,13 +24,13 @@ prepare() {
}
build() {
- RUSTUP_TOOLCHAIN=stable cargo build --release --manifest-path=$pkgname/Cargo.toml --target-dir=target --all-features
+ RUSTUP_TOOLCHAIN=stable cargo build --release --manifest-path=$pkgname/Cargo.toml --target-dir=$pkgname/target --all-features
}
#check() {
-# RUSTUP_TOOLCHAIN=stable cargo test --release --manifest-path=$pkgname/Cargo.toml --target-dir=target
+# RUSTUP_TOOLCHAIN=stable cargo test --release --manifest-path=$pkgname/Cargo.toml --target-dir=$pkgname/target
#}
package() {
- install -Dm755 "target/release/${pkgname%-git}" -t "$pkgdir/usr/bin"
+ install -Dm755 "$pkgname/target/release/${pkgname%-git}" -t "$pkgdir/usr/bin"
}