summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCampbell Jones2023-04-26 21:24:09 -0400
committerCampbell Jones2023-04-26 21:24:09 -0400
commitacf62a1836f7064ed562323b42fc93c64d1306f1 (patch)
tree86f3406673e5b4f267f3c64d4ab3654e54d19e86 /PKGBUILD
parent44e45f9b0c09a9019e8995f446295dbb074f6e1f (diff)
downloadaur-acf62a1836f7064ed562323b42fc93c64d1306f1.tar.gz
Update build steps and deps, add gschema defaults
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 98e432b2a05a..0a793c54b73c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,27 @@
# Maintainer: Campbell Jones <dev at serebit dot com>
pkgname=budgie-desktop-git
-pkgver=10.7.r0.g8855cc2e
+pkgver=10.7.1.r29.g868c87eb
pkgrel=1
pkgdesc="A familiar, modern desktop environment - latest git"
arch=('x86_64' 'armv7h' 'aarch64')
url="https://github.com/BuddiesOfBudgie/budgie-desktop"
license=('GPL2' 'LGPL')
depends=('budgie-screensaver' 'budgie-control-center' 'gnome-bluetooth' 'gnome-menus' 'gnome-session' 'gnome-themes-standard'
- 'libgee' 'libpeas' 'libwnck3' 'mutter' 'accountsservice' 'sassc' 'ibus')
-makedepends=('meson' 'git' 'gobject-introspection' 'intltool' 'vala' 'gtk-doc')
+ 'libgee' 'libpeas' 'libwnck3' 'mutter' 'accountsservice' 'ibus' 'zenity')
+makedepends=('git' 'gobject-introspection' 'intltool' 'meson' 'dart-sass' 'vala' 'gtk-doc')
optdepends=('budgie-desktop-view: Desktop icons'
'budgie-backgrounds: Default background set'
- 'network-manager-applet: Network management')
+ 'network-manager-applet: Network management in the panel'
+ 'switcheroo-control: Open apps with the secondary GPU')
provides=('budgie-desktop')
conflicts=('budgie-desktop')
source=("$pkgname"::'git+https://github.com/BuddiesOfBudgie/budgie-desktop.git'
- "gvc"::"git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git")
+ "gvc"::"git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git"
+ "30_org.archlinux.budgie-desktop.gschema.override")
sha256sums=('SKIP'
- 'SKIP')
+ 'SKIP'
+ '8bf90523787a7acf907adff557e0f578d8516f76c4c63aefe1395250f497324a')
pkgver() {
cd "$pkgname"
@@ -34,10 +37,11 @@ prepare() {
}
build() {
- arch-meson "$pkgname" build
+ arch-meson "$pkgname" build -Duse-old-zenity=true
meson compile -C build
}
package() {
meson install -C build --destdir "$pkgdir"
+ install -Dm 644 30_org.archlinux.budgie-desktop.gschema.override -t "${pkgdir}/usr/share/glib-2.0/schemas"
}