summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorrobson-662022-09-12 13:14:04 +0200
committerrobson-662022-09-12 13:14:04 +0200
commit18e501ffd42f75d9bf4ce0331bef054ad771b41b (patch)
treeedfb6a5d24270cee75d1f7982390b884620aba77 /PKGBUILD
downloadaur-buuf-smplayer.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9a44b28aa7bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Robert Brzozowski <robson75@linux.pl>
+
+pkgname=buuf-smplayer
+pkgver=1.0
+pkgrel=0
+pkgdesc="Theme for SMPlayer"
+arch=('any')
+url="https://github.com/robson-66/Buuf-smplayer"
+license=('cc-by-nc-sa')
+depends=('smplayer' 'smplayer-themes')
+
+source=("https://github.com/robson-66/Buuf-smplayer/archive/refs/tags/v1.0.tar.gz")
+sha256sums=('a84497e8bcb0f4f522fa9c4b88a8db65bfe0f81eaf21f7e726e3ce399b467576')
+
+package() {
+ mkdir -p "$pkgdir"/usr/share/smplayer/themes/
+ cp -R "$srcdir"/Buuf-smplayer*/ "$pkgdir"/usr/share/smplayer/themes/Buuf/
+
+ find $pkgdir/usr -type f -exec chmod 644 {} \;
+ find $pkgdir/usr -type d -exec chmod 755 {} \;
+ find $pkgdir/usr -type f -name '.directory' -delete
+}