summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoranthraxx2015-07-28 22:02:36 +0200
committeranthraxx2015-07-28 22:02:36 +0200
commit7b2dfb4bc7f381ad7cbdd2059d1b6a60e535cb87 (patch)
tree0f28ff5c9f2ceb5cbfcbab0aa58eee544efc771c /PKGBUILD
downloadaur-byacc-bison.tar.gz
addpkg: byacc-bison 1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c32322a774f3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
+
+pkgname=byacc-bison
+pkgver=1
+pkgrel=1
+pkgdesc="A Berkeley reimplementation of the Unix parser generator Yacc (providing bison/yacc)"
+url="http://invisible-island.net/byacc/"
+arch=('any')
+license=('custom')
+depends=('byacc')
+provides=('bison')
+conflicts=('bison')
+source=()
+
+package() {
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ ln -sf /usr/share/licenses/byacc/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ install -d "${pkgdir}/usr/bin"
+ ln -sf /usr/bin/byacc "${pkgdir}/usr/bin/yacc"
+ ln -sf /usr/bin/byacc "${pkgdir}/usr/bin/bison"
+
+ install -d "${pkgdir}/usr/share/man/man1"
+ ln -sf /usr/share/man/man1/byacc.1.gz "${pkgdir}/usr/share/man/man1/yacc.1.gz"
+ ln -sf /usr/share/man/man1/byacc.1.gz "${pkgdir}/usr/share/man/man1/bison.1.gz"
+}
+
+# vim:set ts=2 sw=2 et: