summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authornshepperd2021-07-07 02:51:31 +1000
committernshepperd2021-07-07 02:51:31 +1000
commitf1130223f28f3eed2019af83fcd3d583007e9145 (patch)
tree559ff227441cd8f1f4ac96a22443004c7023b2eb /PKGBUILD
parent16524e73b87ac8396aacba5c96f76bfd697f09f3 (diff)
downloadaur-cabal-static.tar.gz
Add python3 to makedepends because it is required by the bootstrap script now.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a4e7d10ff2e2..89341dd224a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Neil Shepperd <nshepperd at gmail dot com>
pkgname=cabal-static
pkgver=3.4.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="The command-line interface for Cabal and Hackage. Statically linked."
arch=('i686' 'x86_64' 'armv7h')
url="https://hackage.haskell.org/package/cabal-install"
license=('custom:BSD3')
depends=('gmp' 'zlib' 'libffi')
-makedepends=('ghc' 'ghc-static')
+makedepends=('ghc' 'ghc-static' 'python3')
provides=(cabal-install)
conflicts=(cabal-install)
source=("https://hackage.haskell.org/package/cabal-install-${pkgver}/cabal-install-${pkgver}.tar.gz"
@@ -69,7 +69,7 @@ build() {
exit 1
fi
- python "${srcdir}"/bootstrap.py -d "${srcdir}"/arch-${ghcver}.json -w $GHC
+ python3 "${srcdir}"/bootstrap.py -d "${srcdir}"/arch-${ghcver}.json -w $GHC
}
package() {