summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEcho J2024-05-11 21:12:07 +0300
committerEcho J2024-05-11 21:12:07 +0300
commit3e77279e8463d08d9831a65541136ea4c0702ace (patch)
tree7d5492b8fd74dd9f5fd125361d3693bebf484c77 /PKGBUILD
parent51c0a63bc8e38d6d45c9ab72e527013c05fed341 (diff)
downloadaur-cambalache-git.tar.gz
Update the package with my own style
And use SPDX license tags/add .gitignore
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 22 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 59386af63733..9d144849a8c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,35 @@
-# Maintainer: Princeton Ferro (prince781) <princetonferro[at]gmail[dot]com>
+# Maintainer: Echo J. <aidas957 at gmail dot com>
+# Contributor: Princeton Ferro (prince781) <princetonferro[at]gmail[dot]com>
+# shellcheck shell=bash disable=SC2034,SC2164
-pkgname=cambalache-git
_pkgname=cambalache
-pkgver=0.8.1.r204.g2f601c6
+pkgname=cambalache-git
+pkgver=0.90.2.r7.gad89e6b
pkgrel=1
-pkgdesc='A new RAD tool for Gtk 4 and 3 with a clear MVC design and data model first philosophy'
-url=https://gitlab.gnome.org/jpu/cambalache
-arch=(any)
-license=(LGPL)
-depends+=('python-gobject' 'glib2' 'gtk3' 'python-lxml' 'webkit2gtk')
-optdepends=('gtk4')
-makedepends+=(git 'meson>=0.50.0' 'cmake')
-conflicts=($_pkgname)
-provides=($_pkgname=$pkgver)
-source=('git+https://gitlab.gnome.org/jpu/cambalache.git')
+pkgdesc="A new RAD tool for Gtk 4 and 3 (Git version)"
+url="https://gitlab.gnome.org/jpu/cambalache"
+arch=('x86_64')
+license=('LGPL-2.1-only')
+depends=('glib2' 'gtk3' 'gtk4' 'gtksourceview5' 'libadwaita' 'libhandy' 'python-gobject'
+ 'python-lxml' 'webkit2gtk-4.1' 'webkitgtk-6.0')
+depends+=('wlroots-git') # TODO: Switch to regular wlroots when 0.18.0 gets released
+makedepends=('git' 'meson' 'ninja')
+conflicts=("${_pkgname}")
+provides=("${_pkgname}=${pkgver}")
+source=("git+${url}.git")
sha512sums=('SKIP')
pkgver() {
- cd "$_pkgname"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "${_pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- arch-meson cambalache build
+ arch-meson "${_pkgname}" build
- ninja -C build
+ meson compile -C build
}
-package_cambalache-git() {
- DESTDIR="$pkgdir" ninja -C build install
+package() {
+ meson install -C build --destdir "${pkgdir}"
}