summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorrern2022-04-25 13:58:37 +0000
committerrern2022-04-25 13:58:37 +0000
commita9649506478bc72e91fe21b2e28d7032d8a9e780 (patch)
treef14e47f957ddcf13f4f6bbd6967efb77b5497430 /PKGBUILD
parent1ad9bf8828a8025db960cdae2ffd3c795f5f550a (diff)
downloadaur-camillagui.tar.gz
Add depend - python-yaml
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d1c157988ebe..06b103254463 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,15 +15,15 @@ sha256sums=(6c70a8950a9dc3c8752efa77d60ec863035913d7775411034dd21c8b9a603bf3
816138c492d68e291375971a95f88e13d665a21e39202dfce7443c57b4d1d240)
build() {
- installdir=$srcdir/srv/http/settings/camillagui
- mkdir -p $installdir
- unzip camillagui.zip -d $installdir
- rm $installdir/*.{md,txt}
- sed -i 's/"build")$/"build", follow_symlinks=True)/' $installdir/backend/routes.py
+ installdir=$srcdir/srv/http/settings/camillagui
+ mkdir -p $installdir
+ unzip camillagui.zip -d $installdir
+ rm $installdir/*.{md,txt}
+ sed -i 's/"build")$/"build", follow_symlinks=True)/' $installdir/backend/routes.py
}
package() {
- depends=(camilladsp
+ depends=(camilladsp
python-aiohttp
python-jsonschema
python-matplotlib
@@ -31,8 +31,9 @@ package() {
python-pycamilladsp
python-pycamilladsp-plot
python-websocket-client
- python-websockets)
- mv $srcdir/srv $pkgdir
- install -d $pkgdir/$installdir
- install -Dm 644 camillagui.service -t $pkgdir/usr/lib/systemd/system
+ python-websockets
+ python-yaml)
+ mv $srcdir/srv $pkgdir
+ install -d $pkgdir/$installdir
+ install -Dm 644 camillagui.service -t $pkgdir/usr/lib/systemd/system
}