summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohannes Frankenau2017-11-04 19:01:33 +0100
committerJohannes Frankenau2017-11-04 19:02:20 +0100
commit709bb8205b1a39c9574065dbc88a731907680712 (patch)
tree057fb5d24e5b686f96d891799678ceb649919aa8 /PKGBUILD
parent7117bc305d4e0aa95ea2e626b502f8129b16ca97 (diff)
downloadaur-cargo-script.tar.gz
Update to version 0.2.9 and add README and LICENSE
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b53a63689e37..ef2593cbf8aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
pkgname=cargo-script
-pkgver=0.2.0
+pkgver=0.2.9
pkgrel=1
pkgdesc="Quickly and easily run Rust \"scripts\""
url="https://github.com/DanielKeep/cargo-script"
-depends=('cargo')
+depends=('cargo' 'rust')
arch=('i686' 'x86_64')
license=('MIT')
-source=("git+https://github.com/DanielKeep/cargo-script.git#commit=11ad368ff6dfa862629b2d0864dcaa958caba33f")
+source=("git+https://github.com/DanielKeep/cargo-script.git#commit=614e60e5932e218ebff1e471303eb0d59870d03b")
sha256sums=('SKIP')
build() {
@@ -16,6 +16,10 @@ build() {
package() {
cd "$pkgname"
+
install -Dm755 target/release/run-cargo-script "$pkgdir/usr/bin/run-cargo-script"
install -Dm755 target/release/cargo-script "$pkgdir/usr/bin/cargo-script"
+
+ install -Dm644 "README.md" "$pkgdir/usr/share/doc/$pkgname/README.md"
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}