summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDominic2021-04-25 00:02:09 +0200
committerDominic2021-04-25 00:11:03 +0200
commit003d549a044eccbd1b6d1e393a43f484e132043d (patch)
treee025e707d53e3055b5cea801a6cc3092d233e703 /PKGBUILD
parent06a347c0615724b48c67778d3a6b5031946c6c21 (diff)
downloadaur-cargo-sort-ck.tar.gz
auto-update cargo-sort-ck 2.1.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 12 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d474e18645e9..d034a6410281 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,36 +2,31 @@
# Maintainer: Dominic Meiser [git at msrd0 dot de]
# Package Information
-pkgname=cargo-sort-ck
+_crate="cargo-sort-ck"
+pkgname="$_crate"
pkgver=2.1.1
-pkgrel=1
+pkgrel=2
pkgdesc='Check if tables and items in a .toml file are lexically sorted'
-arch=('x86_64')
license=('Apache' 'MIT')
+# Tier 1 architectures supported by Rust (https://doc.rust-lang.org/nightly/rustc/platform-support.html#tier-1)
+arch=('aarch64' 'i686' 'x86_64')
+
# Generic Stuff for cargo packages
-url="https://crates.io/crates/$pkgname"
+url="https://crates.io/crates/$_crate"
depends=('gcc-libs')
makedepends=('cargo')
-source=("$pkgname.tar.gz::https://crates.io/api/v1/crates/$pkgname/$pkgver/download")
+source=("$pkgname-$pkgver.tar.gz::https://crates.io/api/v1/crates/$_crate/$pkgver/download")
sha512sums=('90d2c18ffb944960eb2f4b5e264c9b9b5537942afc8cf26581a72390776bd9f1caf355943b9d1eb245cde4302fa4d0e1e3df44474ce72be95b569529c946703c')
build() {
cd "$srcdir/$pkgname-$pkgver"
-
- # crates.io packages aren't supposed to contain a Cargo.lock file so
- # don't use --locked flag
- cargo build --release
+ cargo build \
+ --locked \
+ --release
}
package() {
cd "$srcdir/$pkgname-$pkgver"
-
- # change this if the crate has other binaries as well!
- install -Dm755 "target/release/$pkgname" -t "$pkgdir/usr/bin"
-
- # install whatever license files the distribution included
- for file in $(ls | grep -i -e license -e copying -e copyring); do
- install -Dm644 "$file" -t "$pkgdir/usr/share/licenses/$pkgname"
- done
+ install -Dm755 "target/release/cargo-sort-ck" -t "$pkgdir/usr/bin"
}