summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorquininer2018-05-27 11:10:51 +0800
committerquininer2018-05-27 11:10:51 +0800
commitf3d83085064e7ec5b4783c60748ea2f9117a22de (patch)
treef5078d98f6a8b6ec864b15901c6fd59a0b245cdd /PKGBUILD
downloadaur-cargo-xbuild-git.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f0f40ca407e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+pkgname=cargo-xbuild-git
+_pkgname=cargo-xbuild
+pkgdesc="Automatically cross-compiles the sysroot crates core, compiler_builtins, and alloc."
+pkgrel=1
+pkgver=0.4.2.287
+arch=('i686' 'x86_64')
+conflicts=("cargo-xbuild")
+provides=("cargo-xbuild")
+url="https://github.com/rust-osdev/cargo-xbuild"
+license=('Apache' 'MIT')
+depends=('rust' 'cargo')
+makedepends=('rust' 'cargo')
+optdepends=('rust-src: rust std source code')
+source=("$_pkgname::git+https://github.com/rust-osdev/cargo-xbuild")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ echo "$(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2).$(git rev-list --count HEAD)"
+}
+
+build() {
+ cd $_pkgname
+ env CARGO_INCREMENTAL=0 cargo build --release
+}
+
+package() {
+ cd $_pkgname
+ install -D -m755 "$srcdir/$_pkgname/target/release/cargo-xbuild" "$pkgdir/usr/bin/cargo-xbuild"
+}